summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-12-16 17:04:42 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-12-16 17:04:42 +0000
commit7ac239dd9c02db11f91e60abb33b2da7bd7b51da (patch)
treedb363c142008fee1f7a93403f54c30ac606547a8 /sci-physics/root
parentStable on ppc64; bug #202168 (diff)
downloadgentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.tar.gz
gentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.tar.bz2
gentoo-2-7ac239dd9c02db11f91e60abb33b2da7bd7b51da.zip
Added patch to fix linking problem with afs libs. Re-added afs USE flag.
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/ChangeLog7
-rw-r--r--sci-physics/root/files/root-5.16.00-afs.patch33
-rw-r--r--sci-physics/root/root-5.16.00-r1.ebuild12
3 files changed, 46 insertions, 6 deletions
diff --git a/sci-physics/root/ChangeLog b/sci-physics/root/ChangeLog
index ae77aa282b43..2d9336de01cb 100644
--- a/sci-physics/root/ChangeLog
+++ b/sci-physics/root/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/root
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.17 2007/12/16 05:05:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/ChangeLog,v 1.18 2007/12/16 17:04:42 markusle Exp $
+
+ 16 Dec 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/root-5.16.00-afs.patch, root-5.16.00-r1.ebuild:
+ Added patch to fix linking problem with afs libs. Re-added afs
+ USE flag.
*root-5.16.00-r1 (15 Dec 2007)
diff --git a/sci-physics/root/files/root-5.16.00-afs.patch b/sci-physics/root/files/root-5.16.00-afs.patch
new file mode 100644
index 000000000000..cf709362aca8
--- /dev/null
+++ b/sci-physics/root/files/root-5.16.00-afs.patch
@@ -0,0 +1,33 @@
+diff -Naur root/configure root.new/configure
+--- root/configure 2007-06-07 02:48:25.000000000 -0500
++++ root.new/configure 2007-12-16 07:18:51.000000000 -0500
+@@ -307,7 +307,7 @@
+ # the .lib export library to link.
+ libs=""
+ for i in $lib ; do
+- for ext in .a .lib "" ; do # lib without extension for MacOS X
++ for ext in foobar "" ; do # lib without extension for MacOS X
+ libs="$libs $i$ext"
+ done
+ done
+@@ -403,7 +403,7 @@
+ flib=""
+ maclib=""
+ for i in $lib ; do
+- for ext in .a .lib "" ; do # lib without extension for MacOS X
++ for ext in foobar "" ; do # lib without extension for MacOS X
+ if test "x$found_lib" = "x$i$ext" ; then
+ flib=$i$ext
+ if test "x$ext" = "x" ; then
+diff -Naur root/xrootd/Module.mk root.new/xrootd/Module.mk
+--- root/xrootd/Module.mk 2007-03-24 09:06:26.000000000 -0500
++++ root.new/xrootd/Module.mk 2007-12-16 07:25:47.000000000 -0500
+@@ -77,6 +77,8 @@
+ gunzip -c $(XROOTDVERS).src.tgz | tar xf -; \
+ etag=`basename $(XROOTDETAG)` ; \
+ touch $$etag ; \
++ sed -e "s:.a .lib:.foobar:" -i xrootd/configure.classic ; \
++ sed -e "s:-lXrdSys:-lXrdSys -lresolv:" -i xrootd/src/XrdSecpwd/GNUmakefile ; \
+ fi)
+ ifeq ($(PLATFORM),win32)
+ @(if [ -d $(XROOTDDIRD)/pthreads-win32 ]; then \
diff --git a/sci-physics/root/root-5.16.00-r1.ebuild b/sci-physics/root/root-5.16.00-r1.ebuild
index 64ab3146cb6c..5868e77b9614 100644
--- a/sci-physics/root/root-5.16.00-r1.ebuild
+++ b/sci-physics/root/root-5.16.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00-r1.ebuild,v 1.1 2007/12/16 05:05:17 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/root/root-5.16.00-r1.ebuild,v 1.2 2007/12/16 17:04:42 markusle Exp $
inherit versionator flag-o-matic eutils toolchain-funcs qt3 fortran
@@ -16,7 +16,7 @@ SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~amd64 ~sparc ~x86"
-IUSE="cern doc fftw kerberos ldap mysql odbc postgres
+IUSE="afs cern doc fftw kerberos ldap mysql odbc postgres
python ruby qt3 ssl truetype xml"
DEPEND="sys-apps/shadow
@@ -26,6 +26,7 @@ DEPEND="sys-apps/shadow
virtual/opengl
virtual/glu
|| ( media-libs/libafterimage x11-wm/afterstep )
+ afs? ( net-fs/openafs )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql )
kerberos? ( virtual/krb5 )
@@ -64,6 +65,7 @@ src_unpack() {
# patch to properly set link flags with fortran compilers
epatch "${FILESDIR}"/${P}-fortran.patch
epatch "${DISTDIR}"/${P}-gcc-4.2.patch.bz2
+ epatch "${FILESDIR}"/${P}-afs.patch
if [[ ${ARCH} == sparc ]]; then
cd "${S}/xrootd/src"
tar xzf xrootd-20060928-1600.src.tgz
@@ -82,7 +84,7 @@ src_compile() {
target=linuxicc
fi
fi
- #use afs && append-flags -DAFS_OLD_COM_ERR
+ use afs && append-flags -DAFS_OLD_COM_ERR
local myfortran
use cern && myfortran="F77=${FORTRANC}"
@@ -137,7 +139,7 @@ src_compile() {
--enable-table \
--enable-unuran \
--enable-xrootd \
- --disable-afs \
+ $(use_enable afs) \
$(use_enable cern) \
$(use_enable fftw fftw3) \
$(use_enable kerberos krb5) \
@@ -155,7 +157,7 @@ src_compile() {
${EXTRA_CONF} \
|| die "configure failed"
- emake -j1 \
+ emake \
OPTFLAGS="${CXXFLAGS}" \
${myfortran} \
|| die "emake failed"