summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-14 18:33:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-14 18:33:46 +0000
commit1bfac4d149085b2d7bd63a7f966d86a39dd933ee (patch)
treecf96db82beb815f901fb9a1ad3bd573b1d826dce /sci-physics
parentRemove ruby19 keyword. (diff)
downloadgentoo-2-1bfac4d149085b2d7bd63a7f966d86a39dd933ee.tar.gz
gentoo-2-1bfac4d149085b2d7bd63a7f966d86a39dd933ee.tar.bz2
gentoo-2-1bfac4d149085b2d7bd63a7f966d86a39dd933ee.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/meep/ChangeLog7
-rw-r--r--sci-physics/meep/meep-1.0.3.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sci-physics/meep/ChangeLog b/sci-physics/meep/ChangeLog
index 1aac8c17226a..14883912eee7 100644
--- a/sci-physics/meep/ChangeLog
+++ b/sci-physics/meep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-physics/meep
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.9 2009/03/18 15:29:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/ChangeLog,v 1.10 2009/07/14 18:33:46 bicatali Exp $
+
+*meep-1.0.3 (14 Jul 2009)
+
+ 14 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +meep-1.0.3.ebuild:
+ Version bump
*meep-0.20.4 (18 Mar 2009)
diff --git a/sci-physics/meep/meep-1.0.3.ebuild b/sci-physics/meep/meep-1.0.3.ebuild
new file mode 100644
index 000000000000..e23ed2e501c4
--- /dev/null
+++ b/sci-physics/meep/meep-1.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/meep/meep-1.0.3.ebuild,v 1.1 2009/07/14 18:33:46 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Simulation software to model electromagnetic systems"
+HOMEPAGE="http://ab-initio.mit.edu/meep/"
+SRC_URI="http://ab-initio.mit.edu/meep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bindist examples hdf5 guile mpi"
+
+DEPEND="sci-libs/fftw
+ !bindist? ( sci-libs/gsl )
+ bindist? ( <sci-libs/gsl-1.10 )
+ sci-physics/harminv
+ guile? ( >=sci-libs/libctl-3.0.3 )
+ hdf5? ( sci-libs/hdf5 )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_with mpi) \
+ $(use_with hdf5) \
+ $(use_with guile libctl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die "install examples failed"
+ fi
+}