summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-12-23 00:26:04 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-12-23 00:26:04 +0000
commitdaa46dd323823d8094de39072a84e3a32a54f559 (patch)
treee8b146caf72fbfa3465f5727c8b891f068484e39 /sci-physics
parentUnbundle gflags and gtest. (diff)
downloadgentoo-2-daa46dd323823d8094de39072a84e3a32a54f559.tar.gz
gentoo-2-daa46dd323823d8094de39072a84e3a32a54f559.tar.bz2
gentoo-2-daa46dd323823d8094de39072a84e3a32a54f559.zip
fix python dep
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/espresso++/ChangeLog5
-rw-r--r--sci-physics/espresso++/espresso++-1.3.1.ebuild13
2 files changed, 12 insertions, 6 deletions
diff --git a/sci-physics/espresso++/ChangeLog b/sci-physics/espresso++/ChangeLog
index 5aff1ad653eb..887c1dd554e0 100644
--- a/sci-physics/espresso++/ChangeLog
+++ b/sci-physics/espresso++/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-physics/espresso++
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.2 2012/10/09 18:10:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/ChangeLog,v 1.3 2012/12/23 00:26:04 ottxor Exp $
+
+ 23 Dec 2012; Christoph Junghans <ottxor@gentoo.org> espresso++-1.3.1.ebuild:
+ fix python dep
09 Oct 2012; Kacper Kowalik <xarthisius@gentoo.org> espresso++-1.3.1.ebuild:
Fix SRC_URI, previous address had SSL cert problems
diff --git a/sci-physics/espresso++/espresso++-1.3.1.ebuild b/sci-physics/espresso++/espresso++-1.3.1.ebuild
index 5bb062827b34..bde7ceda61e8 100644
--- a/sci-physics/espresso++/espresso++-1.3.1.ebuild
+++ b/sci-physics/espresso++/espresso++-1.3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.3.1.ebuild,v 1.2 2012/10/09 18:10:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso++/espresso++-1.3.1.ebuild,v 1.3 2012/12/23 00:26:04 ottxor Exp $
EAPI=4
-PYTHON_DEPEND="2"
+PYTHON_DEPEND="2:2.6"
inherit cmake-utils python
@@ -16,7 +16,8 @@ if [[ ${PV} = 9999 ]]; then
EHG_REVISION="default"
inherit mercurial
else
- SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN%++}pp_${PV//./_}.tgz"
+ SRC_URI="https://www.espresso-pp.de/Download/${PN%++}pp_${PV//./_}.tgz"
+ S="${WORKDIR}/${PN%++}pp"
fi
LICENSE="GPL-3"
@@ -31,10 +32,12 @@ RDEPEND="
DEPEND="${RDEPEND}"
-S="${WORKDIR}/${PN%++}pp"
-
DOCS=( AUTHORS NEWS README )
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use system-boost EXTERNAL_BOOST)