summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-06 04:13:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-06 04:13:27 +0000
commit75a7e90be066114fa2e172c0d3a85dc959bc1276 (patch)
treecc9fba4c988ee364adb099402d607c2f39f4f39a /sci-visualization/extrema
parentVersion bump and removed uneeded .la files (bug #299340) (diff)
downloadgentoo-2-75a7e90be066114fa2e172c0d3a85dc959bc1276.tar.gz
gentoo-2-75a7e90be066114fa2e172c0d3a85dc959bc1276.tar.bz2
gentoo-2-75a7e90be066114fa2e172c0d3a85dc959bc1276.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization/extrema')
-rw-r--r--sci-visualization/extrema/ChangeLog10
-rw-r--r--sci-visualization/extrema/extrema-4.4.2.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/sci-visualization/extrema/ChangeLog b/sci-visualization/extrema/ChangeLog
index ece989354bf0..52902f15e1af 100644
--- a/sci-visualization/extrema/ChangeLog
+++ b/sci-visualization/extrema/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/extrema
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.5 2008/12/06 17:04:22 grozin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.6 2010/01/06 04:13:27 bicatali Exp $
+
+*extrema-4.4.2 (06 Jan 2010)
+
+ 06 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ +extrema-4.4.2.ebuild:
+ Version bump
06 Dec 2008; Andrey Grozin <grozin@gentoo.org> -files/extrema-4.3.5.patch,
-extrema-4.3.5.ebuild, extrema-4.3.6.ebuild:
diff --git a/sci-visualization/extrema/extrema-4.4.2.ebuild b/sci-visualization/extrema/extrema-4.4.2.ebuild
new file mode 100644
index 000000000000..a9e2caaab5dc
--- /dev/null
+++ b/sci-visualization/extrema/extrema-4.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/extrema-4.4.2.ebuild,v 1.1 2010/01/06 04:13:27 bicatali Exp $
+
+EAPI=2
+WX_GTK_VER="2.8"
+inherit eutils fdo-mime wxwidgets
+
+DESCRIPTION="Interactive data analysis and visualization tool"
+HOMEPAGE="http://exsitewebware.com/extrema/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+# File collision, see bug #249423
+RDEPEND="!sci-chemistry/psi
+ >=x11-libs/wxGTK-2.8.7
+ dev-util/desktop-file-utils"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # extrema cannot be compiled with versions of minuit
+ # available in portage
+ econf --enable-shared
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry ${PN}
+ dodir /usr/share/icons/hicolor
+ tar xjf extrema_icons.tar.bz2 -C "${D}usr/share/icons/hicolor"
+ dosym /usr/share/icons/hicolor/48x48/apps/extrema.png /usr/share/pixmaps/extrema.png
+
+ dodoc AUTHORS ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins Scripts/*.pcm Scripts/*.dat || die
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}