summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-02-10 16:50:34 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-02-10 16:50:34 +0000
commitf1a5ba79e176358a1380c33aa9c2fef9ba109f03 (patch)
treec412871e184c985752e3e4f1c7e0569c440e6570 /sci-visualization/extrema
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-f1a5ba79e176358a1380c33aa9c2fef9ba109f03.tar.gz
gentoo-2-f1a5ba79e176358a1380c33aa9c2fef9ba109f03.tar.bz2
gentoo-2-f1a5ba79e176358a1380c33aa9c2fef9ba109f03.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-visualization/extrema')
-rw-r--r--sci-visualization/extrema/ChangeLog8
-rw-r--r--sci-visualization/extrema/extrema-4.4.3.ebuild (renamed from sci-visualization/extrema/extrema-4.3.6.ebuild)28
2 files changed, 23 insertions, 13 deletions
diff --git a/sci-visualization/extrema/ChangeLog b/sci-visualization/extrema/ChangeLog
index b61ff53f5d9d..0c7e3191109e 100644
--- a/sci-visualization/extrema/ChangeLog
+++ b/sci-visualization/extrema/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-visualization/extrema
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.7 2010/01/07 02:06:02 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/ChangeLog,v 1.8 2010/02/10 16:50:34 grozin Exp $
+
+*extrema-4.4.3 (10 Feb 2010)
+
+ 10 Feb 2010; Andrey Grozin <grozin@gentoo.org> -extrema-4.3.6.ebuild,
+ +extrema-4.4.3.ebuild:
+ Version bump
07 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> extrema-4.4.2.ebuild:
Fixed possible sandbox violation (bug #299954)
diff --git a/sci-visualization/extrema/extrema-4.3.6.ebuild b/sci-visualization/extrema/extrema-4.4.3.ebuild
index 21cf27663019..266b6cefa728 100644
--- a/sci-visualization/extrema/extrema-4.3.6.ebuild
+++ b/sci-visualization/extrema/extrema-4.4.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/extrema-4.3.6.ebuild,v 1.2 2008/12/06 17:04:22 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/extrema/extrema-4.4.3.ebuild,v 1.1 2010/02/10 16:50:34 grozin Exp $
+EAPI=2
WX_GTK_VER="2.8"
inherit eutils fdo-mime wxwidgets
@@ -12,23 +13,27 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
# File collision, see bug #249423
-DEPEND="!sci-chemistry/psi
+RDEPEND="!sci-chemistry/psi
>=x11-libs/wxGTK-2.8.7
dev-util/desktop-file-utils"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e 's/$(pkgdatadir)/$(DESTDIR)$(pkgdatadir)/g' \
+ src/Makefile.in || die
+}
-src_compile() {
+src_configure() {
# extrema cannot be compiled with versions of minuit
# available in portage
econf --enable-shared
- emake || die "emake failed"
}
src_install() {
- # The upstream Makefile is mostly OK, but for a few files
- # cp to a hard-coded directory is used, ignoring $(DESTDIR)
- # This problem is solved by einstall
- einstall || die "einstall failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
make_desktop_entry ${PN}
dodir /usr/share/icons/hicolor
@@ -38,13 +43,12 @@ src_install() {
dodoc AUTHORS ChangeLog || die "dodoc failed"
if use doc; then
insinto /usr/share/doc/${PF}
- doins doc/*.pdf
+ doins doc/*.pdf || die
fi
if use examples; then
- dodir /usr/share/doc/${PF}/examples
insinto /usr/share/doc/${PF}/examples
- doins Scripts/*.pcm Scripts/*.dat
+ doins Scripts/*.pcm Scripts/*.dat || die
fi
}