summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-08-27 07:21:51 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-08-27 07:21:51 +0000
commitbdc5cc8ee501b8e43e37ab7441bc141741010dd0 (patch)
treee87fd0f377b67479c8fb626145042acc95bcc392 /sci-visualization
parentVersion bump for bug #328335. (diff)
downloadgentoo-2-bdc5cc8ee501b8e43e37ab7441bc141741010dd0.tar.gz
gentoo-2-bdc5cc8ee501b8e43e37ab7441bc141741010dd0.tar.bz2
gentoo-2-bdc5cc8ee501b8e43e37ab7441bc141741010dd0.zip
Respect CC and LDFLAGS wrt bug 334715. Thanks to Diego for the report. Clean ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/spectromatic/ChangeLog10
-rw-r--r--sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch15
-rw-r--r--sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild (renamed from sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild)30
3 files changed, 32 insertions, 23 deletions
diff --git a/sci-visualization/spectromatic/ChangeLog b/sci-visualization/spectromatic/ChangeLog
index 1def9eecb7d9..aa8c8af8e307 100644
--- a/sci-visualization/spectromatic/ChangeLog
+++ b/sci-visualization/spectromatic/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-visualization/spectromatic
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.6 2010/06/23 20:13:47 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/ChangeLog,v 1.7 2010/08/27 07:21:50 xarthisius Exp $
+
+*spectromatic-1.0-r2 (27 Aug 2010)
+
+ 27 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ -spectromatic-1.0-r1.ebuild, +spectromatic-1.0-r2.ebuild,
+ files/spectromatic-1.0-makefile.patch:
+ Respect CC and LDFLAGS wrt bug 334715. Thanks to Diego for the report.
+ Clean ebuild.
23 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org>
spectromatic-1.0.ebuild, spectromatic-1.0-r1.ebuild:
diff --git a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
index 941cb3bd39da..6636484f876e 100644
--- a/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
+++ b/sci-visualization/spectromatic/files/spectromatic-1.0-makefile.patch
@@ -1,10 +1,14 @@
---- spectromatic-1.0/Makefile 2002-03-30 05:17:34.000000000 +0000
-+++ spectromatic-1.0.new/Makefile 2008-11-26 10:43:15.910065276 +0000
+Respect LDFLAGS, CFLAGS, CC #334715
+Fix install paths
+
+--- Makefile
++++ Makefile
@@ -1,33 +1,29 @@
# Makefile for spectromatic
-CFLAGS = -O2 -Wall
- LIBS = -lgsl -lgslcblas -lpng -lm
+-LIBS = -lgsl -lgslcblas -lpng -lm
++LIBS = -lpng `pkg-config --libs gsl`
DESTDIR =
TOPLEVEL_HOME = /usr
@@ -23,10 +27,11 @@
- install -o root -g root -m 0644 man/spectromatic.1 $(DESTDIR)$(TOPLEVEL_HOME)/man/man1
-
all: $(OBJ)
- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
+- $(CC) -o $(TARGET) $(OBJ) $(LIBS)
- strip $(TARGET)
++ $(CC) $(LDFLAGS) -o $(TARGET) $(OBJ) $(LIBS)
+
-+install: all
++install: $(TARGET)
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/bin
+ mkdir -p $(DESTDIR)$(TOPLEVEL_HOME)/share/man/man1
+ install -m 0755 spectromatic $(DESTDIR)$(TOPLEVEL_HOME)/bin
diff --git a/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild b/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild
index b61ed6c532b8..336c2b0a81eb 100644
--- a/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild
+++ b/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0-r1.ebuild,v 1.3 2010/06/23 20:19:42 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-visualization/spectromatic/spectromatic-1.0-r2.ebuild,v 1.1 2010/08/27 07:21:51 xarthisius Exp $
-inherit eutils
+EAPI=2
-MY_P="spectromatic_1.0-1"
+inherit base toolchain-funcs
+
+MY_P=${PN}_${PV}-1
DESCRIPTION="Generates time-frequency analysis images from wav files"
HOMEPAGE="http://ieee.uow.edu.au/~daniel/software/spectromatic/"
@@ -14,21 +16,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND="media-libs/libpng
+RDEPEND="media-libs/libpng
sci-libs/gsl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-makefile.patch
- epatch "${FILESDIR}"/${P}-stringliteral.patch
-}
-
-src_compile() {
- emake || die "emake failed"
-}
+DOCS=( README )
+PATCHES=( "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-stringliteral.patch" )
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README
+pkg_setup() {
+ tc-export CC
}