summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2004-06-30 00:28:52 +0000
committerChris PeBenito <pebenito@gentoo.org>2004-06-30 00:28:52 +0000
commiteba75c53ac0f9a2f9a80f39d6d8707aa25e2b227 (patch)
treefa1cb2406a6ae23c74cfb6be56700b28dede4d90 /sec-policy
parentremove cruft, take two (diff)
downloadgentoo-2-eba75c53ac0f9a2f9a80f39d6d8707aa25e2b227.tar.gz
gentoo-2-eba75c53ac0f9a2f9a80f39d6d8707aa25e2b227.tar.bz2
gentoo-2-eba75c53ac0f9a2f9a80f39d6d8707aa25e2b227.zip
new release
Diffstat (limited to 'sec-policy')
-rw-r--r--sec-policy/selinux-base-policy/ChangeLog10
-rw-r--r--sec-policy/selinux-base-policy/files/digest-selinux-base-policy-200406291
-rw-r--r--sec-policy/selinux-base-policy/selinux-base-policy-20040629.ebuild89
3 files changed, 99 insertions, 1 deletions
diff --git a/sec-policy/selinux-base-policy/ChangeLog b/sec-policy/selinux-base-policy/ChangeLog
index 39ab5630d264..06960dffbb54 100644
--- a/sec-policy/selinux-base-policy/ChangeLog
+++ b/sec-policy/selinux-base-policy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sec-policy/selinux-base-policy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.26 2004/06/28 00:10:36 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/ChangeLog,v 1.27 2004/06/30 00:28:52 pebenito Exp $
+
+*selinux-base-policy-20040629 (29 Jun 2004)
+
+ 29 Jun 2004; Chris PeBenito <pebenito@gentoo.org>
+ +selinux-base-policy-20040629.ebuild:
+ Large sysadmfile cleanup: disable admin_separation to give sysadm_r back its
+ ablility to modify all files. Minor fixes: portage_r works again, syslog-ng
+ breakage fixed, put back manual PaX policy for pageexec/segmexec.
16 Jun 2004; Chris PeBenito <pebenito@gentoo.org>
selinux-base-policy-20040604.ebuild:
diff --git a/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040629 b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040629
new file mode 100644
index 000000000000..d7060dfe3e2a
--- /dev/null
+++ b/sec-policy/selinux-base-policy/files/digest-selinux-base-policy-20040629
@@ -0,0 +1 @@
+MD5 fc887edb668623ab77c0696b99c7c0c2 selinux-base-policy-20040629.tar.bz2 69301
diff --git a/sec-policy/selinux-base-policy/selinux-base-policy-20040629.ebuild b/sec-policy/selinux-base-policy/selinux-base-policy-20040629.ebuild
new file mode 100644
index 000000000000..5464fe3a04ae
--- /dev/null
+++ b/sec-policy/selinux-base-policy/selinux-base-policy-20040629.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-base-policy/selinux-base-policy-20040629.ebuild,v 1.1 2004/06/30 00:28:52 pebenito Exp $
+
+IUSE="build"
+
+DESCRIPTION="Gentoo base policy for SELinux"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/selinux/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+DEPEND="build? ( sys-devel/make
+ sys-devel/m4 )"
+RDEPEND="sys-devel/m4
+ sys-devel/make"
+
+S=${WORKDIR}/base-policy
+
+[ -z ${POLICYDIR} ] && POLICYDIR="/etc/security/selinux/src/policy"
+
+# deprecated policies:
+DEPRECATED="domains/program/devfsd.te domains/program/opt.te
+ file_contexts/program/devfsd.fc file_contexts/program/opt.fc
+ file_contexts/users.fc"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ if use build; then
+ # generate a file_contexts
+ dodir ${POLICYDIR}/file_contexts
+ einfo "Ignore the checkpolicy error on the next line."
+ make -C ${S} \
+ FC=${D}/${POLICYDIR}/file_contexts/file_contexts \
+ ${D}/${POLICYDIR}/file_contexts/file_contexts
+
+ [ ! -f ${D}/${POLICYDIR}/file_contexts/file_contexts ] && \
+ die "file_contexts was not generated."
+ else
+ # install full policy
+ dodir /etc/security/selinux/src
+
+ insinto /etc/security
+ doins ${S}/appconfig/*
+
+ cp -a ${S} ${D}/${POLICYDIR}
+ rm -fR ${D}/${POLICYDIR}/appconfig
+ fi
+}
+
+pkg_postinst() {
+ local isdeprecated
+ echo
+ einfo "This is the base policy for SELinux on Gentoo. This policy"
+ einfo "package only covers the applications in the system profile."
+ einfo "More policy may need to be added according to your requirements."
+ echo
+ eerror "It is STRONGLY suggested that you evaluate and merge the"
+ eerror "policy changes. If any of the file contexts (*.fc) have"
+ eerror "changed, you should also relabel."
+ echo
+ ewarn "Please check the Changelog, there may be important information."
+ echo
+ echo
+
+ einfo "Checking for deprecated policy..."
+ for i in $DEPRECATED; do
+ if [ -f "${POLICYDIR}/${i}" ]; then
+ eerror "${POLICYDIR}/${i}"
+ isdeprecated="y"
+ fi
+ done
+ [ "${isdeprecated}" ] && \
+ eerror "The above policy file(s) should be removed if possible." || \
+ einfo "None found."
+
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ echo -ne "\a" ; sleep 0.1 ; echo -ne "\a" ; sleep 1
+ sleep 4
+}