summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-17 12:33:36 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-17 12:33:36 +0000
commit4a050044e47030c7b3be970c074e60941ae6ade7 (patch)
tree586108cf30379bada018c057f87dd98a38e276c2 /sys-apps/attr
parentserious security update, everyone should update, reported by Ferry Meyndert, ... (diff)
downloadgentoo-2-4a050044e47030c7b3be970c074e60941ae6ade7.tar.gz
gentoo-2-4a050044e47030c7b3be970c074e60941ae6ade7.tar.bz2
gentoo-2-4a050044e47030c7b3be970c074e60941ae6ade7.zip
fixed writes out of image dir and corrected symlinks
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/attr-1.1.3-r1.ebuild38
-rw-r--r--sys-apps/attr/files/digest-attr-1.1.3-r11
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-apps/attr/attr-1.1.3-r1.ebuild b/sys-apps/attr/attr-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..7c6cbe30bbe3
--- /dev/null
+++ b/sys-apps/attr/attr-1.1.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-1.1.3-r1.ebuild,v 1.1 2002/01/17 12:33:36 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/latest/cmd_tars/${P}.src.tar.gz"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+
+DEPEND="virtual/glibc sys-devel/autoconf sys-devel/make"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ cd ${S}
+ export OPTIMIZER="${CFLAGS}"
+ export DEBUG=-DNDEBUG
+ autoconf || die
+ ./configure --prefix=/usr || die
+ # 1) add a ${DESTDIR} prefix to all install paths so we can relocate during the "install" phase
+ # 2) we also set the /usr/share/doc/ directory to the correct value.
+ # 3) we remove a hard-coded "-O1"
+ # 4) we fix some Makefile-created library symlinks that contains absolute paths
+ cp include/builddefs include/builddefs.orig
+ sed -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e "s:/usr/share/doc/${PN}:/usr/share/doc/${PF}:" \
+ -e 's:-O1::' \
+ -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs.orig > include/builddefs || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install install-dev || die
+ dosym /usr/lib/libattr.a /lib/libattr.a
+ dosym /usr/lib/libattr.la /lib/libattr.la
+ dosym /lib/libattr.so /usr/lib/libattr.la
+}
diff --git a/sys-apps/attr/files/digest-attr-1.1.3-r1 b/sys-apps/attr/files/digest-attr-1.1.3-r1
new file mode 100644
index 000000000000..906484eca2d7
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-1.1.3-r1
@@ -0,0 +1 @@
+MD5 907b7cabb8a8a5cfef7fdd7dcafd1039 attr-1.1.3.src.tar.gz 53248