summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-28 23:41:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-28 23:41:06 +0000
commite9dafa6aeb3b75aeb5cc2e6faa6a0ab52bbf8e28 (patch)
tree26dc184c6c3b087dd00c973f4e32313b7ee9818c /sys-apps/attr
parentmigrate binaries and shared library to / filesystem for use when /usr is not ... (diff)
downloadgentoo-2-e9dafa6aeb3b75aeb5cc2e6faa6a0ab52bbf8e28.tar.gz
gentoo-2-e9dafa6aeb3b75aeb5cc2e6faa6a0ab52bbf8e28.tar.bz2
gentoo-2-e9dafa6aeb3b75aeb5cc2e6faa6a0ab52bbf8e28.zip
migrate binaries and shared library to / filesystem for use when /usr is not available, as per bug #27064
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/ChangeLog8
-rw-r--r--sys-apps/attr/Manifest4
-rw-r--r--sys-apps/attr/attr-2.4.7-r1.ebuild66
-rw-r--r--sys-apps/attr/files/digest-attr-2.4.7-r11
4 files changed, 76 insertions, 3 deletions
diff --git a/sys-apps/attr/ChangeLog b/sys-apps/attr/ChangeLog
index 7d415d595257..8a84455ecf10 100644
--- a/sys-apps/attr/ChangeLog
+++ b/sys-apps/attr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/attr
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.17 2003/08/12 01:42:46 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/ChangeLog,v 1.18 2003/08/28 23:41:03 robbat2 Exp $
+
+*attr-2.4.7-r1 (28 Aug 2003)
+
+ 28 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> attr-2.4.7-r1.ebuild:
+ migrate binaries and shared library to / filesystem for use when /usr is not
+ available, as per bug #27064
*attr-2.4.7 (11 Aug 2003)
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index d139195e5340..baa816ef3823 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1,9 +1,9 @@
-MD5 b771b4e2e5d08dbde71db8c65afbf2f8 attr-2.4.7-r1.ebuild 1625
+MD5 546d998717fcd71fa888ce4fe692e8d9 attr-2.4.7-r1.ebuild 1541
MD5 959c89b6f43469751b6a4480b96d5348 attr-2.4.7.ebuild 1551
MD5 5efd458241d9b683ae95cd2936b59af5 attr-2.2.0.ebuild 1287
MD5 8d577ecd6a060adab35bc91064fc076d attr-2.4.1.ebuild 1358
MD5 f837b3d37451b45992d9793be44e48e0 attr-2.1.1-r1.ebuild 1166
-MD5 1286d9267d4de4740b3e05c6542a8668 ChangeLog 2980
+MD5 f9d112c4103fb7df22f07f4bfa763825 ChangeLog 3196
MD5 74e751203db2d18c328b77951c4e5396 files/attr-2.4.1-gettext.diff 1208
MD5 b57048711f1d8bc6ae87ea34a3dc212f files/digest-attr-2.2.0 123
MD5 5176e6e3d5d11a771451a6f2d845d48b files/digest-attr-2.4.1 65
diff --git a/sys-apps/attr/attr-2.4.7-r1.ebuild b/sys-apps/attr/attr-2.4.7-r1.ebuild
new file mode 100644
index 000000000000..80b9ec4ecc49
--- /dev/null
+++ b/sys-apps/attr/attr-2.4.7-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/attr/attr-2.4.7-r1.ebuild,v 1.1 2003/08/28 23:41:03 robbat2 Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="xfs extended attributes tools"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${P}.src.tar.gz
+ http://acl.bestbits.at/current/tar/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~amd64 ~mips ~ppc"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-apps/sed-4.0.5
+ virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=sys-devel/gcc-3*"
+RDEPEND="virtual/glibc"
+
+IUSE="nls debug"
+
+src_compile() {
+ if use debug; then
+ DEBUG=-DDEBUG
+ OPTIMIZER="-g"
+ CFLAGS=
+ CXXFLAGS=
+ export DEBUG OPTIMIZER CFLAGS CXXFLAGS
+ else
+ DEBUG=-DNDEBUG
+ OPTIMIZER=""
+ # note that CFLAGS is already inherited!
+ export DEBUG OPTIMIZER
+ fi
+
+ local myconf="`use_enable nls gettext`"
+ econf ${myconf} || die
+
+ sed -i \
+ -e 's:^PKG_\(.*\)_DIR = \(.*\)$:PKG_\1_DIR = ${DESTDIR}\2:' \
+ -e 's:-O1::' -e 's:../$(INSTALL) -S \(.*\) $(PKG_.*_DIR)/\(.*$\)::' \
+ include/builddefs
+
+ make || die
+}
+
+src_install() {
+ dodir /lib
+ dodir /usr/lib
+ dodir /bin
+ dodir /usr/bin
+
+ make DIST_ROOT=${D} \
+ install install-lib install-dev || die
+
+ # install docs in correct place
+ mv ${D}/usr/share/doc/attr ${D}/usr/share/doc/${PF}
+ prepalldocs
+
+ mv ${D}/usr/bin/* ${D}/bin
+ mv ${D}/usr/lib/libattr.so* ${D}/lib
+
+ dosym /lib/libattr.so /usr/lib/libattr.so
+}
diff --git a/sys-apps/attr/files/digest-attr-2.4.7-r1 b/sys-apps/attr/files/digest-attr-2.4.7-r1
new file mode 100644
index 000000000000..d5fe24a2977e
--- /dev/null
+++ b/sys-apps/attr/files/digest-attr-2.4.7-r1
@@ -0,0 +1 @@
+MD5 56e67402f5075ce47b5657b4336ff563 attr-2.4.7.src.tar.gz 84674