summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-12 09:48:23 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-12 09:48:23 +0000
commit07e648ed215bfe3fc1a9e25b2b6ef5efad584a3e (patch)
tree8bf112654f7fc1e668c2e3d53a574dd3ffece5f5 /sys-apps/bash
parentUpdate, required for bash-2.05 (diff)
downloadgentoo-2-07e648ed215bfe3fc1a9e25b2b6ef5efad584a3e.tar.gz
gentoo-2-07e648ed215bfe3fc1a9e25b2b6ef5efad584a3e.tar.bz2
gentoo-2-07e648ed215bfe3fc1a9e25b2b6ef5efad584a3e.zip
Just another update
Diffstat (limited to 'sys-apps/bash')
-rw-r--r--sys-apps/bash/bash-2.05.ebuild85
-rw-r--r--sys-apps/bash/files/digest-bash-2.051
2 files changed, 86 insertions, 0 deletions
diff --git a/sys-apps/bash/bash-2.05.ebuild b/sys-apps/bash/bash-2.05.ebuild
new file mode 100644
index 000000000000..9de44e5220b7
--- /dev/null
+++ b/sys-apps/bash/bash-2.05.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bash/bash-2.05.ebuild,v 1.1 2001/04/12 09:48:23 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bash/${A}
+ ftp://ftp.gnu.org/gnu/bash/${A}"
+
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2
+ readline? ( >=sys-libs/readline-4.2 )
+ tex? ( app-text/tetex )
+ "
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ local myconf
+ if [ "`use readline`" ]
+ then
+ myconf="--with-installed-readline"
+ fi
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ try ./configure --prefix=/ --mandir=/usr/share/man \
+ --infodir=/usr/share/info --host=${CHOST} \
+ --disable-profiling --with-curses \
+ --enable-static-link ${myconf}
+
+ try pmake
+
+ if [ "`use tex`" ] && [ -z "`use build`" ]
+ then
+ cd support
+ cp texi2html texi2html.orig
+ sed -e "s:/usr/local/bin/perl:/usr/bin/perl:" \
+ texi2html.orig > texi2html
+ cd ../doc
+ try make
+ fi
+
+}
+
+
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info install
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ if [ -z "`use build`" ]
+ then
+ doman doc/*.1
+
+ if [ -z "`use readline`" ]
+ then
+ doman doc/*.3
+ fi
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+
+ if [ "`use tex`" ]
+ then
+ docinto html
+ dodoc doc/*.html
+ docinto ps
+ dodoc doc/*.ps
+ fi
+ else
+ rm -rf ${D}/usr
+ fi
+
+}
+
diff --git a/sys-apps/bash/files/digest-bash-2.05 b/sys-apps/bash/files/digest-bash-2.05
new file mode 100644
index 000000000000..fa4c95cd969a
--- /dev/null
+++ b/sys-apps/bash/files/digest-bash-2.05
@@ -0,0 +1 @@
+MD5 fe40d1633203c1ca6f2a6dfc6d097c48 bash-2.05.tar.gz