summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-28 16:53:47 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-28 16:53:47 +0000
commit21ff097fd7a506a3d2fe9a548be36949eb344908 (patch)
treef9b796cd08a16277c45fabf4115065b391a437f0 /sys-apps/busybox
parentstable ppc, bug 328131 (diff)
downloadgentoo-2-21ff097fd7a506a3d2fe9a548be36949eb344908.tar.gz
gentoo-2-21ff097fd7a506a3d2fe9a548be36949eb344908.tar.bz2
gentoo-2-21ff097fd7a506a3d2fe9a548be36949eb344908.zip
Move .config setup to src_prepare, fix from upstream for nano timestamps #335947 by Sergio Costas, and propagate strict aliasing workaround for stable preparation.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog8
-rw-r--r--sys-apps/busybox/busybox-1.17.1-r1.ebuild5
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-date.patch32
-rw-r--r--sys-apps/busybox/files/busybox-1.17.1-grep.patch39
4 files changed, 82 insertions, 2 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 9d04a94177cb..cc8b54cecb1e 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.255 2010/08/22 17:34:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.256 2010/09/28 16:53:47 vapier Exp $
+
+ 28 Sep 2010; Mike Frysinger <vapier@gentoo.org> busybox-1.17.1-r1.ebuild,
+ +files/busybox-1.17.1-date.patch, +files/busybox-1.17.1-grep.patch:
+ Move .config setup to src_prepare, fix from upstream for nano timestamps
+ #335947 by Sergio Costas, and propagate strict aliasing workaround for
+ stable preparation.
22 Aug 2010; Mike Frysinger <vapier@gentoo.org>
+files/busybox-1.17.1-make.patch:
diff --git a/sys-apps/busybox/busybox-1.17.1-r1.ebuild b/sys-apps/busybox/busybox-1.17.1-r1.ebuild
index 331bd31a0ee3..cfc174ca28e4 100644
--- a/sys-apps/busybox/busybox-1.17.1-r1.ebuild
+++ b/sys-apps/busybox/busybox-1.17.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.1-r1.ebuild,v 1.1 2010/08/16 21:23:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.17.1-r1.ebuild,v 1.2 2010/09/28 16:53:47 vapier Exp $
EAPI=2
inherit eutils flag-o-matic savedconfig toolchain-funcs
@@ -81,6 +81,7 @@ busybox_config_option() {
src_prepare() {
unset KBUILD_OUTPUT #88088
+ append-flags -fno-strict-aliasing #310413
# patches go here!
epatch "${FILESDIR}"/busybox-1.17.0-bb.patch
@@ -98,7 +99,9 @@ src_prepare() {
-e "/^CC/s:=.*:= $(tc-getCC):" \
-e "/^HOSTCC/s:=.*:= $(tc-getBUILD_CC):" \
Makefile || die
+}
+src_configure() {
# check for a busybox config before making one of our own.
# if one exist lets return and use it.
diff --git a/sys-apps/busybox/files/busybox-1.17.1-date.patch b/sys-apps/busybox/files/busybox-1.17.1-date.patch
new file mode 100644
index 000000000000..4dfad710b984
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.17.1-date.patch
@@ -0,0 +1,32 @@
+http://bugs.gentoo.org/335947
+
+From f2da16f451812f40bed51fd60a304df3d7dfc1bd Mon Sep 17 00:00:00 2001
+From: Denys Vlasenko <vda.linux@googlemail.com>
+Date: Sun, 6 Jun 2010 17:53:48 +0200
+Subject: [PATCH] date: make FEATURE_NANO compile on glibc systems
+
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+---
+ coreutils/date.c | 6 +++++-
+ 1 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/coreutils/date.c b/coreutils/date.c
+index c599df7..3d78a53 100644
+--- a/coreutils/date.c
++++ b/coreutils/date.c
+@@ -204,7 +204,11 @@ int date_main(int argc UNUSED_PARAM, char **argv)
+ xstat(filename, &statbuf);
+ ts.tv_sec = statbuf.st_mtime;
+ #if ENABLE_FEATURE_DATE_NANO
+- ts.tv_nsec = statbuf.st_mtim.tv_nsec;
++# if defined __GLIBC__ && !defined __UCLIBC__
++ ts.tv_nsec = statbuf.st_mtim.tv_nsec;
++# else
++ ts.tv_nsec = statbuf.st_mtimensec;
++# endif
+ #endif
+ } else {
+ #if ENABLE_FEATURE_DATE_NANO
+--
+1.7.3
+
diff --git a/sys-apps/busybox/files/busybox-1.17.1-grep.patch b/sys-apps/busybox/files/busybox-1.17.1-grep.patch
new file mode 100644
index 000000000000..f8fc25d3f3fe
--- /dev/null
+++ b/sys-apps/busybox/files/busybox-1.17.1-grep.patch
@@ -0,0 +1,39 @@
+diff -urpN busybox-1.17.1/findutils/grep.c busybox-1.17.1-grep/findutils/grep.c
+--- busybox-1.17.1/findutils/grep.c 2010-07-06 04:25:54.000000000 +0200
++++ busybox-1.17.1-grep/findutils/grep.c 2010-08-23 02:37:08.000000000 +0200
+@@ -461,15 +461,19 @@ static int grep_file(FILE *file)
+ if (found)
+ print_line(gl->pattern, strlen(gl->pattern), linenum, ':');
+ } else while (1) {
++ unsigned start = gl->matched_range.rm_so;
+ unsigned end = gl->matched_range.rm_eo;
++ unsigned len = end - start;
+ char old = line[end];
+ line[end] = '\0';
+- print_line(line + gl->matched_range.rm_so,
+- end - gl->matched_range.rm_so,
+- linenum, ':');
++ /* Empty match is not printed: try "echo test | grep -o ''" */
++ if (len != 0)
++ print_line(line + start, len, linenum, ':');
+ if (old == '\0')
+ break;
+ line[end] = old;
++ if (len == 0)
++ end++;
+ #if !ENABLE_EXTRA_COMPAT
+ if (regexec(&gl->compiled_regex, line + end,
+ 1, &gl->matched_range, REG_NOTBOL) != 0)
+diff -urpN busybox-1.17.1/testsuite/grep.tests busybox-1.17.1-grep/testsuite/grep.tests
+--- busybox-1.17.1/testsuite/grep.tests 2010-07-06 04:25:54.000000000 +0200
++++ busybox-1.17.1-grep/testsuite/grep.tests 2010-08-23 02:37:08.000000000 +0200
+@@ -98,5 +98,9 @@ testing "grep -o does not loop forever"
+ 'grep -o "[^/]*$"' \
+ "test\n" \
+ "" "/var/test\n"
++testing "grep -o does not loop forever on zero-length match" \
++ 'grep -o "" | head -n1' \
++ "" \
++ "" "test\n"
+
+ exit $FAILCOUNT