summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-08-07 02:48:40 +0000
committerMike Frysinger <vapier@gentoo.org>2006-08-07 02:48:40 +0000
commit2c2eef3d92c47f16718c0ecf8c809eac6830b09b (patch)
tree81a43bbf5723a03da5d6fe50d40beeab1a224f64 /sys-apps/busybox
parentfix nested break and abort if user config not found #141640 (diff)
downloadgentoo-2-2c2eef3d92c47f16718c0ecf8c809eac6830b09b.tar.gz
gentoo-2-2c2eef3d92c47f16718c0ecf8c809eac6830b09b.tar.bz2
gentoo-2-2c2eef3d92c47f16718c0ecf8c809eac6830b09b.zip
simpler .config fix from Jac Goudsmit
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/busybox-1.1.3.ebuild15
-rw-r--r--sys-apps/busybox/busybox-1.2.0.ebuild15
-rw-r--r--sys-apps/busybox/busybox-1.2.1.ebuild15
3 files changed, 15 insertions, 30 deletions
diff --git a/sys-apps/busybox/busybox-1.1.3.ebuild b/sys-apps/busybox/busybox-1.1.3.ebuild
index f3eec6282a01..ce3ce033a874 100644
--- a/sys-apps/busybox/busybox-1.1.3.ebuild
+++ b/sys-apps/busybox/busybox-1.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.14 2006/08/07 02:45:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.1.3.ebuild,v 1.15 2006/08/07 02:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -73,19 +73,14 @@ src_unpack() {
for root in "${ROOT}" / ; do
configfile=${root}etc/portage/savedconfig/${conf}.config
if [[ -r ${configfile} ]] ; then
+ einfo "Found your ${configfile} and using it."
cp ${configfile} "${S}"/.config
- break
+ yes "" | make oldconfig > /dev/null
+ return 0
fi
done
- [[ -e .config ]] && break
done
- if [[ -r ${S}/.config ]] ; then
- einfo "Found your ${configfile} and using it."
- yes "" | make oldconfig > /dev/null
- return 0
- else
- die "Could not locate user configfile, please fix"
- fi
+ die "Could not locate user configfile, please fix"
fi
if use netboot ; then
cp "${FILESDIR}"/config-netboot .config
diff --git a/sys-apps/busybox/busybox-1.2.0.ebuild b/sys-apps/busybox/busybox-1.2.0.ebuild
index 40a6248c12cc..ba14b9f18f74 100644
--- a/sys-apps/busybox/busybox-1.2.0.ebuild
+++ b/sys-apps/busybox/busybox-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.6 2006/08/07 02:45:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.0.ebuild,v 1.7 2006/08/07 02:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -73,19 +73,14 @@ src_unpack() {
for root in "${ROOT}" / ; do
configfile=${root}etc/portage/savedconfig/${conf}.config
if [[ -r ${configfile} ]] ; then
+ einfo "Found your ${configfile} and using it."
cp ${configfile} "${S}"/.config
- break
+ yes "" | make oldconfig > /dev/null
+ return 0
fi
done
- [[ -e .config ]] && break
done
- if [[ -r ${S}/.config ]] ; then
- einfo "Found your ${configfile} and using it."
- yes "" | make oldconfig > /dev/null
- return 0
- else
- die "Could not locate user configfile, please fix"
- fi
+ die "Could not locate user configfile, please fix"
fi
if use netboot ; then
cp "${FILESDIR}"/config-netboot .config
diff --git a/sys-apps/busybox/busybox-1.2.1.ebuild b/sys-apps/busybox/busybox-1.2.1.ebuild
index 1a4621a364a4..8ad437aead88 100644
--- a/sys-apps/busybox/busybox-1.2.1.ebuild
+++ b/sys-apps/busybox/busybox-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.2 2006/08/07 02:45:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.2.1.ebuild,v 1.3 2006/08/07 02:48:40 vapier Exp $
inherit eutils flag-o-matic
@@ -73,19 +73,14 @@ src_unpack() {
for root in "${ROOT}" / ; do
configfile=${root}etc/portage/savedconfig/${conf}.config
if [[ -r ${configfile} ]] ; then
+ einfo "Found your ${configfile} and using it."
cp ${configfile} "${S}"/.config
- break
+ yes "" | make oldconfig > /dev/null
+ return 0
fi
done
- [[ -e .config ]] && break
done
- if [[ -r ${S}/.config ]] ; then
- einfo "Found your ${configfile} and using it."
- yes "" | make oldconfig > /dev/null
- return 0
- else
- die "Could not locate user configfile, please fix"
- fi
+ die "Could not locate user configfile, please fix"
fi
if use netboot ; then
cp "${FILESDIR}"/config-netboot .config