summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-25 18:51:27 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-25 18:51:27 +0000
commitd6187f23e28bcdf5a09c6b2409f7df4599a96f23 (patch)
treeeb49fdec273b7d4533246c8da6aa37b15ce09ff7 /sys-apps/busybox
parentRemove older versions (diff)
downloadgentoo-2-d6187f23e28bcdf5a09c6b2409f7df4599a96f23.tar.gz
gentoo-2-d6187f23e28bcdf5a09c6b2409f7df4599a96f23.tar.bz2
gentoo-2-d6187f23e28bcdf5a09c6b2409f7df4599a96f23.zip
Add init.d logic from the live git ebuild.
(Portage version: 2.2.0_alpha159/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/busybox')
-rw-r--r--sys-apps/busybox/ChangeLog5
-rw-r--r--sys-apps/busybox/busybox-1.21.0.ebuild24
2 files changed, 27 insertions, 2 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 0c7ff70158f4..2970f8b401f1 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/busybox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.334 2013/01/22 01:48:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.335 2013/01/25 18:51:27 vapier Exp $
+
+ 25 Jan 2013; Mike Frysinger <vapier@gentoo.org> busybox-1.21.0.ebuild:
+ Add init.d logic from the live git ebuild.
*busybox-1.21.0 (22 Jan 2013)
diff --git a/sys-apps/busybox/busybox-1.21.0.ebuild b/sys-apps/busybox/busybox-1.21.0.ebuild
index fcfb99a91a84..9e76dfcf6a37 100644
--- a/sys-apps/busybox/busybox-1.21.0.ebuild
+++ b/sys-apps/busybox/busybox-1.21.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.21.0.ebuild,v 1.1 2013/01/22 01:48:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-1.21.0.ebuild,v 1.2 2013/01/25 18:51:27 vapier Exp $
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
@@ -45,6 +45,10 @@ busybox_config_option() {
einfo $(grep "CONFIG_$2[= ]" .config || echo Could not find CONFIG_$2 ...)
}
+busybox_config_enabled() {
+ grep "^CONFIG_$1=y" -q .config
+}
+
src_prepare() {
unset KBUILD_OUTPUT #88088
append-flags -fno-strict-aliasing #310413
@@ -197,6 +201,24 @@ src_install() {
dosym busybox /bin/vi
fi
+ # add busybox daemon's, bug #444718
+ if busybox_config_enabled FEATURE_NTPD_SERVER; then
+ newconfd "${FILESDIR}/ntpd.confd" "busybox-ntpd"
+ newinitd "${FILESDIR}/ntpd.initd" "busybox-ntpd"
+ fi
+ if busybox_config_enabled SYSLOGD; then
+ newconfd "${FILESDIR}/syslogd.confd" "busybox-syslogd"
+ newinitd "${FILESDIR}/syslogd.initd" "busybox-syslogd"
+ fi
+ if busybox_config_enabled KLOGD; then
+ newconfd "${FILESDIR}/klogd.confd" "busybox-klogd"
+ newinitd "${FILESDIR}/klogd.initd" "busybox-klogd"
+ fi
+ if busybox_config_enabled WATCHDOG; then
+ newconfd "${FILESDIR}/watchdog.confd" "busybox-watchdog"
+ newinitd "${FILESDIR}/watchdog.initd" "busybox-watchdog"
+ fi
+
# bundle up the symlink files for use later
emake DESTDIR="${ED}" install
rm _install/bin/busybox