summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2008-01-29 15:17:17 +0000
committerChris PeBenito <pebenito@gentoo.org>2008-01-29 15:17:17 +0000
commit78336571f9fc96201a2018d679a5b7c0f61d1c84 (patch)
treec42992a57a0de1385430afa4524bee4d07aa3a95 /sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild
parentalpha/ia64/sparc stable wrt #207634 (diff)
downloadgentoo-2-78336571f9fc96201a2018d679a5b7c0f61d1c84.tar.gz
gentoo-2-78336571f9fc96201a2018d679a5b7c0f61d1c84.tar.bz2
gentoo-2-78336571f9fc96201a2018d679a5b7c0f61d1c84.zip
sys-apps/checkpolicy: new upstream bugfix release.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild b/sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild
new file mode 100644
index 000000000000..b23f7f3948ac
--- /dev/null
+++ b/sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/checkpolicy/checkpolicy-1.34.4.ebuild,v 1.1 2008/01/29 15:17:17 pebenito Exp $
+
+IUSE="debug"
+
+inherit eutils
+
+SEMNG_VER="1.10"
+
+# BUGFIX_PATCH="${FILESDIR}/checkpolicy-1.30.4.diff"
+
+DESCRIPTION="SELinux policy compiler"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="=sys-libs/libsemanage-${SEMNG_VER}*
+ sys-devel/flex
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ [ ! -z "${BUGFIX_PATCH}" ] && epatch "${BUGFIX_PATCH}"
+}
+
+src_compile() {
+ cd ${S}
+ emake YACC="bison -y" || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+
+ if useq debug; then
+ dobin ${S}/test/{dismod,dispol}
+ fi
+}
+
+pkg_postinst() {
+ einfo "This checkpolicy can compile version `checkpolicy -V |cut -f 1 -d ' '` policy."
+}