summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 19:00:16 +0000
committerBjarke Istrup Pedersen <gurligebis@gentoo.org>2010-10-10 19:00:16 +0000
commitfc0db16f4fbb4bb7f8d1d2b4517a97d85238559f (patch)
tree9123b6a7dc887588d637143ce08f6bce6f368fcc /sys-apps/cobalt-panel-utils
parentalpha/sparc stable wrt #336802 (diff)
downloadgentoo-2-fc0db16f4fbb4bb7f8d1d2b4517a97d85238559f.tar.gz
gentoo-2-fc0db16f4fbb4bb7f8d1d2b4517a97d85238559f.tar.bz2
gentoo-2-fc0db16f4fbb4bb7f8d1d2b4517a97d85238559f.zip
Fixing bug #335680
(Portage version: 2.2_rc91/cvs/Linux i686)
Diffstat (limited to 'sys-apps/cobalt-panel-utils')
-rw-r--r--sys-apps/cobalt-panel-utils/ChangeLog8
-rw-r--r--sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.1.ebuild32
-rw-r--r--sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild13
3 files changed, 17 insertions, 36 deletions
diff --git a/sys-apps/cobalt-panel-utils/ChangeLog b/sys-apps/cobalt-panel-utils/ChangeLog
index 377a42bb12b8..e5fe6bcdd7a8 100644
--- a/sys-apps/cobalt-panel-utils/ChangeLog
+++ b/sys-apps/cobalt-panel-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/cobalt-panel-utils
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cobalt-panel-utils/ChangeLog,v 1.7 2008/10/14 02:03:19 darkside Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cobalt-panel-utils/ChangeLog,v 1.8 2010/10/10 19:00:16 gurligebis Exp $
+
+ 10 Oct 2010; <gurligebis@gentoo.org> -cobalt-panel-utils-1.0.1.ebuild,
+ cobalt-panel-utils-1.0.2.ebuild:
+ Removing old version and fixing LDFLAGS wrt. bug #335680
14 Oct 2008; Jeremy Olexa <darkside@gentoo.org>
-cobalt-panel-utils-1.0.0.ebuild, cobalt-panel-utils-1.0.1.ebuild,
diff --git a/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.1.ebuild b/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.1.ebuild
deleted file mode 100644
index f059dca2e366..000000000000
--- a/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.1.ebuild,v 1.2 2008/10/14 02:03:19 darkside Exp $
-
-inherit eutils
-
-DESCRIPTION="LCD and LED panel utilities for the Sun Cobalts"
-HOMEPAGE="http://gentoo.404ster.com/"
-SRC_URI="ftp://www.404ster.com/pub/gentoo-stuff/ebuilds/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-RDEPEND="sys-devel/gettext"
-DEPEND="${RDEPEND}
- sys-devel/autoconf"
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- into /
- dosbin "${S}"/lcd-flash "${S}"/lcd-getip "${S}"/lcd-swrite \
- "${S}"/lcd-write "${S}"/lcd-yesno "${S}"/lcd-setcursor "${S}"/iflink \
- "${S}"/iflinkstatus "${S}"/readbutton || die "dosbin failed"
-
- dodoc doc/README* doc/CREDITS
- doman doc/man/*.1
-}
diff --git a/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild b/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild
index 1b7e3d296afc..be900bf21a02 100644
--- a/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild
+++ b/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild,v 1.4 2008/10/14 02:03:19 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/cobalt-panel-utils/cobalt-panel-utils-1.0.2.ebuild,v 1.5 2010/10/10 19:00:16 gurligebis Exp $
+
+EAPI="2"
inherit eutils
@@ -17,6 +19,13 @@ RDEPEND="sys-devel/gettext"
DEPEND="${DEPEND}
sys-devel/autoconf"
+src_configure() {
+ sed -i \
+ -e"/^COPTS/s:= := ${CFLAGS} :" \
+ -e"/^LDFLAGS/s:= := ${LDFLAGS} :"\
+ Makefile || die "sed failed"
+}
+
src_compile() {
if use static; then
einfo "Building as static executables"