summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-13 17:47:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-13 17:47:33 +0000
commit2ebf28d6ba901e7c4c0b78f26be64b879a32003f (patch)
tree2e139e21f0c3639318063f6a9d2598bc02ce7968 /sys-apps/coreutils
parentlu_zero's a genius (diff)
downloadgentoo-2-2ebf28d6ba901e7c4c0b78f26be64b879a32003f.tar.gz
gentoo-2-2ebf28d6ba901e7c4c0b78f26be64b879a32003f.tar.bz2
gentoo-2-2ebf28d6ba901e7c4c0b78f26be64b879a32003f.zip
lu_zero's a genius
Diffstat (limited to 'sys-apps/coreutils')
-rw-r--r--sys-apps/coreutils/ChangeLog7
-rw-r--r--sys-apps/coreutils/Manifest4
-rw-r--r--sys-apps/coreutils/coreutils-5.0-r4.ebuild18
-rw-r--r--sys-apps/coreutils/files/digest-coreutils-5.0-r42
4 files changed, 24 insertions, 7 deletions
diff --git a/sys-apps/coreutils/ChangeLog b/sys-apps/coreutils/ChangeLog
index 721b43599365..ab7bb29cd23f 100644
--- a/sys-apps/coreutils/ChangeLog
+++ b/sys-apps/coreutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/coreutils
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.29 2003/09/12 12:14:17 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/ChangeLog,v 1.30 2003/09/13 17:47:31 seemant Exp $
+
+ 13 Sep 2003; Seemant Kulleen <seemant@gentoo.org> coreutils-5.0-r4.ebuild:
+ Luca Barbato <lu_zero@gentoo.org> fixed the acl patch to compile with NLS
+ disabled. This should close the NULL not found errors, as reported in bug
+ #18151 by shadow.
12 Sep 2003; Seemant Kulleen <seemant@gentoo.org> coreutils-5.0-r3.ebuild:
Added message about removing fileutils, textutils and sh-utils in
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index 87a1dae8e990..aa0de2704e36 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,8 +1,8 @@
MD5 81aee4964c34d6d2c265ad36c9e34241 coreutils-4.5.11-r1.ebuild 2509
-MD5 61931cb3d1ad17beb4906afd9ef6acf8 coreutils-5.0-r4.ebuild 3232
+MD5 a60b54707861192ebc8abca8fca36559 coreutils-5.0-r4.ebuild 3232
MD5 c1a61b5e143228990ad9ace27f5155d3 coreutils-5.0-r1.ebuild 2728
MD5 9564bbeef93e8d3b1ce385e7f7f5977a coreutils-5.0-r3.ebuild 2879
-MD5 7ac1954a7a3c2ae93b13c7af7b1c76a3 ChangeLog 5376
+MD5 1c72b15122d3120ef565863ffb55ff8c ChangeLog 5626
MD5 8f2bc7ec86685c4ae093a5f5c4f59f82 coreutils-5.0-r2.ebuild 2765
MD5 0ff5f66b1d04c85d2434fa73547e67f3 files/digest-coreutils-4.5.11-r1 207
MD5 d0d4edd45d2bebd31947fec9818be33e files/digest-coreutils-5.0-r1 213
diff --git a/sys-apps/coreutils/coreutils-5.0-r4.ebuild b/sys-apps/coreutils/coreutils-5.0-r4.ebuild
index 460848eb2518..eb0986e9c185 100644
--- a/sys-apps/coreutils/coreutils-5.0-r4.ebuild
+++ b/sys-apps/coreutils/coreutils-5.0-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r4.ebuild,v 1.2 2003/09/12 11:35:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/coreutils/coreutils-5.0-r4.ebuild,v 1.3 2003/09/13 17:47:31 seemant Exp $
inherit eutils
IUSE="nls build acl selinux"
-PATCH_VER=1.5
+PATCH_VER=1.6
S="${WORKDIR}/${P}"
DESCRIPTION="Standard GNU file utilities (chmod, cp, dd, dir, ls...), text utilities (sort, tr, head, wc..), and shell utilities (whoami, who,...)"
@@ -22,6 +22,7 @@ KEYWORDS="~x86 ~amd64 ~ppc ~sparc alpha hppa ~arm ~mips"
DEPEND="virtual/glibc
>=sys-apps/portage-2.0.49
nls? ( sys-devel/gettext )
+ acl? ( sys-apps/acl )
selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
PATCHDIR=${WORKDIR}/patch
@@ -48,6 +49,11 @@ src_unpack() {
if use acl
then
mv ${PATCHDIR}/001* ${PATCHDIR}/excluded
+ if [ -z "`use nls`" ] ; then
+ ewarn "blah"
+ mv ${PATCHDIR}/acl/004* ${PATCHDIR}/excluded
+ ewarn "heh"
+ fi
use selinux || EPATCH_SUFFIX="patch" epatch ${PATCHDIR}/acl
fi
@@ -67,11 +73,17 @@ src_compile() {
local myconf=""
use nls || myconf="--disable-nls"
+ if use acl
+ then
+ mv m4/inttypes.m4 m4/inttypes-eggert.m4
+ autoreconf --force --install || die
+ fi
+
econf \
--bindir=/bin \
${myconf} || die
- if [ "`use static`" ]
+ if use static
then
emake LDFLAGS=-static || die
else
diff --git a/sys-apps/coreutils/files/digest-coreutils-5.0-r4 b/sys-apps/coreutils/files/digest-coreutils-5.0-r4
index 86e66c61a8e1..18ae24692fad 100644
--- a/sys-apps/coreutils/files/digest-coreutils-5.0-r4
+++ b/sys-apps/coreutils/files/digest-coreutils-5.0-r4
@@ -1,3 +1,3 @@
MD5 94e5558ee2a65723d4840bfde2d323f0 coreutils-5.0.tar.bz2 3952653
-MD5 b0038cb7da4db6b0bfe38ad11d8610fa coreutils-gentoo-1.5.tar.bz2 37929
+MD5 ad7913a322709dbc8c0b01f2637c0349 coreutils-gentoo-1.6.tar.bz2 46443
MD5 56309285e57c7175a993c20a2084c0e3 coreutils-5.0-r2-selinux.patch.bz2 20091