summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-09-22 00:29:42 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-09-22 00:29:42 +0000
commit8f9aa8bd9b9c560cab337a0c36c6f2b2f4ba3099 (patch)
treed03e4027de783714b8781a3e494a9cb3394c1517 /sys-apps/dbus-core
parentRemoved the old dbus-0.23 series\! (diff)
downloadgentoo-2-8f9aa8bd9b9c560cab337a0c36c6f2b2f4ba3099.tar.gz
gentoo-2-8f9aa8bd9b9c560cab337a0c36c6f2b2f4ba3099.tar.bz2
gentoo-2-8f9aa8bd9b9c560cab337a0c36c6f2b2f4ba3099.zip
Switched to expat from libxml2. Added tests. Rev bump.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-apps/dbus-core')
-rw-r--r--sys-apps/dbus-core/ChangeLog5
-rw-r--r--sys-apps/dbus-core/dbus-core-0.93.ebuild21
2 files changed, 18 insertions, 8 deletions
diff --git a/sys-apps/dbus-core/ChangeLog b/sys-apps/dbus-core/ChangeLog
index 0a746925159e..ca735459456b 100644
--- a/sys-apps/dbus-core/ChangeLog
+++ b/sys-apps/dbus-core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/dbus-core
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus-core/ChangeLog,v 1.6 2006/09/14 14:23:37 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus-core/ChangeLog,v 1.7 2006/09/22 00:29:42 cardoe Exp $
+
+ 22 Sep 2006; Doug Goldstein <cardoe@gentoo.org> dbus-core-0.93.ebuild:
+ Switched to expat from libxml2. Added tests. Rev bump.
*dbus-core-0.93 (14 Sep 2006)
diff --git a/sys-apps/dbus-core/dbus-core-0.93.ebuild b/sys-apps/dbus-core/dbus-core-0.93.ebuild
index fbd1c264cb18..0ddda7043001 100644
--- a/sys-apps/dbus-core/dbus-core-0.93.ebuild
+++ b/sys-apps/dbus-core/dbus-core-0.93.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus-core/dbus-core-0.93.ebuild,v 1.1 2006/09/14 14:23:37 steev Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus-core/dbus-core-0.93.ebuild,v 1.2 2006/09/22 00:29:42 cardoe Exp $
+WANT_AUTOCONF=2.5
inherit eutils multilib debug autotools
MY_P=${PN/-core/}-${PV}
@@ -11,14 +12,13 @@ SRC_URI="http://dbus.freedesktop.org/releases/${MY_P}.tar.gz"
SLOT="0"
LICENSE="|| ( GPL-2 AFL-2.1 )"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="doc selinux X"
-RDEPEND="X? ( || ( ( x11-libs/libXt x11-libs/libX11 ) virtual/x11 ) )
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
selinux? ( sys-libs/libselinux )
- >=dev-libs/libxml2-2.6.21
+ >=dev-libs/expat-1.95.8
!<sys-apps/dbus-0.91"
- # expat code now sucks.. libxml2 is the default
DEPEND="${RDEPEND}
dev-util/pkgconfig
@@ -28,15 +28,18 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_compile() {
+ local myconf=""
+
+ hasq ${FEATURES} test && myconf="${myconf} --enable-tests=yes"
+
econf \
$(use_with X x) \
$(use_enable kernel_linux dnotify) \
$(use_enable kernel_FreeBSD kqueue) \
$(use_enable selinux) \
$(use_enable debug verbose-mode) \
- $(use_enable debug checks) \
$(use_enable debug asserts) \
- --with-xml=libxml \
+ --with-xml=expat \
--with-system-pid-file=/var/run/dbus.pid \
--with-system-socket=/var/run/dbus/system_bus_socket \
--with-session-socket-dir=/tmp \
@@ -54,6 +57,10 @@ src_compile() {
emake || die "make failed"
}
+src_test() {
+ DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"