summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-10-08 22:12:05 +0000
committerMarinus Schraal <foser@gentoo.org>2004-10-08 22:12:05 +0000
commit5bd532045617d343f1c5aff411b087ccc9cd00ec (patch)
treeda2abc4cbfd4ef089f0e17ec0ea74fec5443b65a /sys-apps/dbus
parentadd intltool dep (Manifest recommit) (diff)
downloadgentoo-2-5bd532045617d343f1c5aff411b087ccc9cd00ec.tar.gz
gentoo-2-5bd532045617d343f1c5aff411b087ccc9cd00ec.tar.bz2
gentoo-2-5bd532045617d343f1c5aff411b087ccc9cd00ec.zip
remove old version
Diffstat (limited to 'sys-apps/dbus')
-rw-r--r--sys-apps/dbus/Manifest4
-rw-r--r--sys-apps/dbus/dbus-0.22.ebuild113
-rw-r--r--sys-apps/dbus/files/digest-dbus-0.221
3 files changed, 4 insertions, 114 deletions
diff --git a/sys-apps/dbus/Manifest b/sys-apps/dbus/Manifest
index 2878f2711219..300633073b4f 100644
--- a/sys-apps/dbus/Manifest
+++ b/sys-apps/dbus/Manifest
@@ -1,3 +1,4 @@
+MD5 0d387d1ecfa6a5d6dca8fdd584737f16 dbus-0.22-r2.ebuild 2928
MD5 e20a3b3aa75fe177e028fbd68b19c1fb dbus-0.22-r1.ebuild 2795
MD5 ee04037b37177649f28e343914554415 dbus-0.22.ebuild 2694
MD5 b956c45919db8aee37212e487a10ee80 ChangeLog 2562
@@ -5,4 +6,7 @@ MD5 5b5bcd9c1a432b2c8157b0004a073f72 metadata.xml 224
MD5 5ad50ae94f784548fc0d6f1364ce23bb files/dbus 544
MD5 032a780f5d3dd0c743f2b932424fd39c files/dbus-0.22-python_int64.patch 5448
MD5 b0cc4f0bb3505fb083602b48c09f25a6 files/digest-dbus-0.22-r1 62
+MD5 b0cc4f0bb3505fb083602b48c09f25a6 files/digest-dbus-0.22-r2 62
+MD5 89670f39c616e08e472a236ed9079b34 files/dbus-0.22-mono_bindings.patch 5122
+MD5 0bbcecc888e29256a5b9a8b1b110099c files/dbus-0.22-bus_driver_know_thyself.patch 1373
MD5 b0cc4f0bb3505fb083602b48c09f25a6 files/digest-dbus-0.22 62
diff --git a/sys-apps/dbus/dbus-0.22.ebuild b/sys-apps/dbus/dbus-0.22.ebuild
deleted file mode 100644
index 339050f358e7..000000000000
--- a/sys-apps/dbus/dbus-0.22.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-0.22.ebuild,v 1.6 2004/09/18 22:17:51 lv Exp $
-
-# because of the experimental nature debug by default
-inherit debug eutils mono
-
-# FIXME : fix docs
-#IUSE="X gtk qt python mono doc xml2"
-IUSE="X gtk qt python mono xml2"
-
-DESCRIPTION="A message bus system, a simple way for applications to talk to eachother"
-HOMEPAGE="http://www.freedesktop.org/software/dbus/"
-SRC_URI="http://www.freedesktop.org/software/dbus/releases/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2 | AFL-2.1"
-KEYWORDS="~x86 ppc ~amd64"
-
-RDEPEND=">=dev-libs/glib-2
- xml2? ( >=dev-libs/libxml2-2.6 )
- !xml2? ( dev-libs/expat )
- X? ( virtual/x11 )
- qt? ( >=x11-libs/qt-3 )
- gtk? ( >=x11-libs/gtk+-2 )
- python? ( >=dev-lang/python-2.2
- >=dev-python/pyrex-0.9 )
- mono? ( >=dev-dotnet/mono-0.95 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-# doc? ( app-doc/doxygen
-# app-text/xmlto )"
-
-# needs gcj, we have no neat way of knowing if it was enabled
-# java? ( sys-devel/gcc )
-
-src_compile() {
-
- local myconf
-
- if use xml2; then
- myconf="--with-xml=libxml";
- else
- myconf="--with-xml=expat";
- fi
-
- econf \
- `use_enable X x` \
- `use_enable gtk` \
- `use_enable qt` \
- `use_enable python` \
- `use_enable mono` \
- --enable-glib \
- --enable-verbose-mode \
- --enable-checks \
- --enable-asserts \
- --with-system-pid-file=/var/run/dbus.pid \
- --with-system-socket=/var/lib/dbus/system_bus_socket \
- --with-session-socket-dir=/tmp \
- --disable-doxygen-docs \
- --disable-xml-docs \
- --disable-mono-docs \
- ${myconf} \
- || die
-
-# `use_enable doc doxygen-docs` \
-# `use_enable doc xml-docs` \
-
- # do not build the mono examples, they need gtk-sharp
- touch ${S}/mono/example/echo-{server,client}.exe
-
- # this gets around a lib64 sandbox bug. note that this addpredict is
- # added automatically by sandbox.c for lib.
- addpredict /usr/lib64/python2.3/
- addpredict /usr/lib64/python2.2/
- addpredict /usr/lib64/python2.1/
-
- emake || die
-
-}
-
-src_install() {
-
- make DESTDIR=${D} install || die
-
- # initscript
- exeinto /etc/init.d/
- doexe ${FILESDIR}/dbus
-
- # needs to exist for the system socket
- keepdir /var/lib/dbus
-
- keepdir /usr/lib/dbus-1.0/services
-
- dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO doc/*html
-
-}
-
-pkg_preinst() {
-
- enewgroup messagebus || die "Problem adding messagebus group"
- enewuser messagebus -1 /bin/false /dev/null messagebus || die "Problem adding messagebus user"
-
-}
-
-pkg_postinst() {
-
- einfo "To start the DBUS system-wide messagebus by default"
- einfo "you should add it to the default runlevel :"
- einfo "\`rc-update add dbus default\`"
-
-}
diff --git a/sys-apps/dbus/files/digest-dbus-0.22 b/sys-apps/dbus/files/digest-dbus-0.22
deleted file mode 100644
index d2af6e21be95..000000000000
--- a/sys-apps/dbus/files/digest-dbus-0.22
+++ /dev/null
@@ -1 +0,0 @@
-MD5 6b1c2476ea8b82dd9fb7f29ef857cb9f dbus-0.22.tar.gz 1248780