summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2000-12-22 20:59:36 +0000
committerDaniel Robbins <drobbins@gentoo.org>2000-12-22 20:59:36 +0000
commitf293eaeb1b8d27bcf284660502b793fa1f31a797 (patch)
treeb1a3e2227b23a4a7f58c469a4c3e1ac40d7c1d04 /sys-apps/dcron
parentsome important fixes (diff)
downloadgentoo-2-f293eaeb1b8d27bcf284660502b793fa1f31a797.tar.gz
gentoo-2-f293eaeb1b8d27bcf284660502b793fa1f31a797.tar.bz2
gentoo-2-f293eaeb1b8d27bcf284660502b793fa1f31a797.zip
A newer, better cron!
Diffstat (limited to 'sys-apps/dcron')
-rw-r--r--sys-apps/dcron/dcron-2.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-apps/dcron/dcron-2.7.ebuild b/sys-apps/dcron/dcron-2.7.ebuild
new file mode 100644
index 000000000000..6355bd118258
--- /dev/null
+++ b/sys-apps/dcron/dcron-2.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dcron/dcron-2.7.ebuild,v 1.1 2000/12/22 20:59:36 drobbins Exp $
+
+A=dcron27.tgz
+S=${WORKDIR}/dcron
+DESCRIPTION="A cute little cron from Matt Dillon"
+SRC_URI="http://apollo.backplane.com/FreeSrc/${A}"
+
+HOMEPAGE="http://apollo.backplane.com"
+
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_compile() {
+ try make
+}
+
+src_install() {
+ dobin crontab
+ dosbin crond
+ chown root.wheel /usr/sbin/crond
+ chown root.cron /usr/bin/crontab
+ chmod 700 ${D}/usr/sbin/crond
+ chmod 4750 ${D}/usr/bin/crontab
+ doman *.[18]
+ diropts -m0750
+ dodir /var/spool/cron/crontabs
+ dodoc CHANGELOG README
+}
+