summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2009-01-30 21:43:47 +0000
committerSven Wegener <swegener@gentoo.org>2009-01-30 21:43:47 +0000
commit1a123e0c7db826818dd271f7ab4f6126930f3151 (patch)
treee974670196e26efc7cc7844efc561b4c188ddfbb /sys-apps/dstat/dstat-0.6.9.ebuild
parentVersion bump, bug #256244. (diff)
downloadgentoo-2-1a123e0c7db826818dd271f7ab4f6126930f3151.tar.gz
gentoo-2-1a123e0c7db826818dd271f7ab4f6126930f3151.tar.bz2
gentoo-2-1a123e0c7db826818dd271f7ab4f6126930f3151.zip
Version bump, bug #256523.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/dstat/dstat-0.6.9.ebuild')
-rw-r--r--sys-apps/dstat/dstat-0.6.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/dstat/dstat-0.6.9.ebuild b/sys-apps/dstat/dstat-0.6.9.ebuild
new file mode 100644
index 000000000000..71ce438afbb3
--- /dev/null
+++ b/sys-apps/dstat/dstat-0.6.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dstat/dstat-0.6.9.ebuild,v 1.1 2009/01/30 21:43:47 swegener Exp $
+
+inherit python
+
+DESCRIPTION="Dstat is a versatile replacement for vmstat, iostat and ifstat"
+HOMEPAGE="http://dag.wieers.com/home-made/dstat/"
+SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/python"
+DEPEND=""
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+
+ dodoc \
+ AUTHORS ChangeLog README TODO \
+ examples/{mstat,read}.py docs/*.txt \
+ || die "dodoc failed"
+ dohtml docs/*.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/dstat
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/dstat
+}