summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-24 16:32:10 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-24 16:32:10 +0000
commitb7b5f14bae18dc3b059a6aeef5f08dde9c31d02b (patch)
tree9f22e18ce893cdb7c4000d5da14008903eae881c /sys-apps/ed
parentcorrection to Changelog (diff)
downloadgentoo-2-b7b5f14bae18dc3b059a6aeef5f08dde9c31d02b.tar.gz
gentoo-2-b7b5f14bae18dc3b059a6aeef5f08dde9c31d02b.tar.bz2
gentoo-2-b7b5f14bae18dc3b059a6aeef5f08dde9c31d02b.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/ed')
-rw-r--r--sys-apps/ed/ChangeLog7
-rw-r--r--sys-apps/ed/ed-1.9.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/sys-apps/ed/ChangeLog b/sys-apps/ed/ChangeLog
index 5c7e750d0897..4f55ca8486dc 100644
--- a/sys-apps/ed/ChangeLog
+++ b/sys-apps/ed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/ed
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.99 2013/04/25 01:37:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ChangeLog,v 1.100 2013/06/24 16:32:10 vapier Exp $
+
+*ed-1.9 (24 Jun 2013)
+
+ 24 Jun 2013; Mike Frysinger <vapier@gentoo.org> +ed-1.9.ebuild:
+ Version bump.
*ed-1.8 (25 Apr 2013)
diff --git a/sys-apps/ed/ed-1.9.ebuild b/sys-apps/ed/ed-1.9.ebuild
new file mode 100644
index 000000000000..112201a1d4b6
--- /dev/null
+++ b/sys-apps/ed/ed-1.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ed/ed-1.9.ebuild,v 1.1 2013/06/24 16:32:10 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Your basic line editor"
+HOMEPAGE="http://www.gnu.org/software/ed/"
+SRC_URI="mirror://gnu/ed/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-apps/texinfo"
+RDEPEND=""
+
+src_configure() {
+ # Upstream configure script is moronic.
+ econf \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ --bindir="${EPREFIX}/bin"
+}