summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-05-20 22:10:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-05-20 22:10:15 +0000
commit52dc34e779d34166b014fb35d8955d3b227ed0c7 (patch)
tree3d9f6610c1f7f052c520d3c9edba36f21640a9aa /sys-apps/elfix
parentRemove older stable (diff)
downloadgentoo-2-52dc34e779d34166b014fb35d8955d3b227ed0c7.tar.gz
gentoo-2-52dc34e779d34166b014fb35d8955d3b227ed0c7.tar.bz2
gentoo-2-52dc34e779d34166b014fb35d8955d3b227ed0c7.zip
Version bump: avoid ELF_C_RDWR_MMAP for uclibc systems
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog6
-rw-r--r--sys-apps/elfix/elfix-0.7.0.ebuild37
-rw-r--r--sys-apps/elfix/elfix-0.8.2.ebuild38
3 files changed, 44 insertions, 37 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index ee081c079e5a..32d5f9f78b21 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,4 +1,10 @@
+*elfix-0.8.2 (20 May 2013)
+
+ 20 May 2013; Anthony G. Basile <blueness@gentoo.org> +elfix-0.8.2.ebuild,
+ -elfix-0.7.0.ebuild:
+ Version bump: avoid ELF_C_RDWR_MMAP for uclibc systems
+
28 Feb 2013; Anthony G. Basile <blueness@gentoo.org> elfix-0.8.1.ebuild:
Depend on any revision of PV, for bug #459632
diff --git a/sys-apps/elfix/elfix-0.7.0.ebuild b/sys-apps/elfix/elfix-0.7.0.ebuild
deleted file mode 100644
index 571b6aed97ce..000000000000
--- a/sys-apps/elfix/elfix-0.7.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.7.0.ebuild,v 1.10 2013/01/10 20:36:10 blueness Exp $
-
-EAPI="4"
-
-DESCRIPTION="Tools to work with ELF binaries and libraries on Hardened Gentoo."
-HOMEPAGE="http://dev.gentoo.org/~blueness/elfix/"
-SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="+ptpax +xtpax"
-
-# These only work on a properly configured pax kernel
-RESTRICT="test"
-
-DEPEND="
- dev-libs/elfutils
- =dev-python/pypax-${PV}[ptpax=,xtpax=]
- xtpax? ( sys-apps/attr )"
-
-RDEPEND="${DEPEND}"
-
-src_configure() {
- rm -f "${S}/scripts/setup.py"
- econf \
- --disable-tests \
- $(use_enable ptpax) \
- $(use_enable xtpax)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
-}
diff --git a/sys-apps/elfix/elfix-0.8.2.ebuild b/sys-apps/elfix/elfix-0.8.2.ebuild
new file mode 100644
index 000000000000..68ffa5722ab7
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.8.2.ebuild,v 1.1 2013/05/20 22:10:15 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="~dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}