summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-06 22:58:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-06 22:58:48 +0000
commit81f5386545eb0d56bb87717848fa4461544fa8b0 (patch)
tree3e5de900b549bdfe41619afd3ff7b5f7fc87fdad /sys-apps/elfix
parentMinor version bump, switch to distutils-r1 and EAPI=5 (diff)
downloadgentoo-2-81f5386545eb0d56bb87717848fa4461544fa8b0.tar.gz
gentoo-2-81f5386545eb0d56bb87717848fa4461544fa8b0.tar.bz2
gentoo-2-81f5386545eb0d56bb87717848fa4461544fa8b0.zip
Minor version bump, switch to EAPI=5
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-apps/elfix')
-rw-r--r--sys-apps/elfix/ChangeLog4
-rw-r--r--sys-apps/elfix/elfix-0.8.1.ebuild38
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-apps/elfix/ChangeLog b/sys-apps/elfix/ChangeLog
index 4af790f19e3d..cc6e5421c222 100644
--- a/sys-apps/elfix/ChangeLog
+++ b/sys-apps/elfix/ChangeLog
@@ -1,4 +1,8 @@
+*elfix-0.8.1 (06 Jan 2013)
+
+ 06 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +elfix-0.8.1.ebuild:
+ Minor version bump, switch to EAPI=5
31 Dec 2012; Jeroen Roovers <jer@gentoo.org> elfix-0.7.0.ebuild:
Stable for HPPA (bug #445334).
diff --git a/sys-apps/elfix/elfix-0.8.1.ebuild b/sys-apps/elfix/elfix-0.8.1.ebuild
new file mode 100644
index 000000000000..71604870903c
--- /dev/null
+++ b/sys-apps/elfix/elfix-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/elfix/elfix-0.8.1.ebuild,v 1.1 2013/01/06 22:58:48 blueness Exp $
+
+EAPI="5"
+
+DESCRIPTION="A suite of tools to work with ELF objects on Hardened Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/pax-quickstart.xml
+ http://dev.gentoo.org/~blueness/elfix/"
+SRC_URI="http://dev.gentoo.org/~blueness/elfix/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+ptpax +xtpax"
+
+REQUIRED_USE="|| ( ptpax xtpax )"
+
+# These only work with a properly configured PaX kernel
+RESTRICT="test"
+
+DEPEND="=dev-python/pypax-${PV}[ptpax=,xtpax=]
+ ptpax? ( dev-libs/elfutils )
+ xtpax? ( sys-apps/attr )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ rm -f "${S}/scripts/setup.py"
+ econf --disable-tests \
+ $(use_enable ptpax) \
+ $(use_enable xtpax)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog INSTALL README THANKS TODO
+}