summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-21 07:22:25 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-21 07:22:25 +0000
commitf481b2ff8be3660eb00e26a00f04794764e3d274 (patch)
tree0047cef52f6dff0f6dacbf2521b5643b144d09db /sys-apps/fakeroot
parentFixing libdir for #470732 (diff)
downloadgentoo-2-f481b2ff8be3660eb00e26a00f04794764e3d274.tar.gz
gentoo-2-f481b2ff8be3660eb00e26a00f04794764e3d274.tar.bz2
gentoo-2-f481b2ff8be3660eb00e26a00f04794764e3d274.zip
Version bump.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/fakeroot')
-rw-r--r--sys-apps/fakeroot/ChangeLog8
-rw-r--r--sys-apps/fakeroot/fakeroot-1.19.ebuild36
-rw-r--r--sys-apps/fakeroot/files/fakeroot-1.19-no-acl_h.patch37
3 files changed, 80 insertions, 1 deletions
diff --git a/sys-apps/fakeroot/ChangeLog b/sys-apps/fakeroot/ChangeLog
index 8b216da217e7..50427985e2d0 100644
--- a/sys-apps/fakeroot/ChangeLog
+++ b/sys-apps/fakeroot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/fakeroot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/ChangeLog,v 1.93 2013/01/11 18:47:22 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/ChangeLog,v 1.94 2013/05/21 07:22:24 radhermit Exp $
+
+*fakeroot-1.19 (21 May 2013)
+
+ 21 May 2013; Tim Harder <radhermit@gentoo.org> +fakeroot-1.19.ebuild,
+ +files/fakeroot-1.19-no-acl_h.patch:
+ Version bump.
11 Jan 2013; Anthony G. Basile <blueness@gentoo.org> fakeroot-1.18.4.ebuild:
Stable ppc, bug #450346, thanks vincent
diff --git a/sys-apps/fakeroot/fakeroot-1.19.ebuild b/sys-apps/fakeroot/fakeroot-1.19.ebuild
new file mode 100644
index 000000000000..00e9a5a77c1d
--- /dev/null
+++ b/sys-apps/fakeroot/fakeroot-1.19.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/fakeroot/fakeroot-1.19.ebuild,v 1.1 2013/05/21 07:22:24 radhermit Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
+HOMEPAGE="http://packages.qa.debian.org/f/fakeroot.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="acl static-libs test"
+
+DEPEND="acl? ( sys-apps/acl )
+ test? ( app-arch/sharutils )"
+
+DOCS="AUTHORS BUGS DEBUG README doc/README.saving"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.19-no-acl_h.patch
+}
+
+src_configure() {
+ export ac_cv_header_sys_acl_h=$(usex acl)
+
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/sys-apps/fakeroot/files/fakeroot-1.19-no-acl_h.patch b/sys-apps/fakeroot/files/fakeroot-1.19-no-acl_h.patch
new file mode 100644
index 000000000000..d208b8ffa43b
--- /dev/null
+++ b/sys-apps/fakeroot/files/fakeroot-1.19-no-acl_h.patch
@@ -0,0 +1,37 @@
+http://bugs.gentoo.org/424419
+
+--- fakeroot-1.19/libfakeroot.c
++++ fakeroot-1.19/libfakeroot.c
+@@ -1908,6 +1908,7 @@
+ return fakeroot_disabled;
+ }
+
++#ifdef HAVE_SYS_ACL_H
+ #ifdef HAVE_ACL_T
+ acl_t acl_get_fd(int fd) {
+ errno = ENOTSUP;
+@@ -1926,6 +1927,7 @@
+ errno = ENOTSUP;
+ return -1;
+ }
++#endif /* HAVE_ACL_T */
+ #endif /* HAVE_SYS_ACL_H */
+
+ #ifdef HAVE_FTS_READ
+--- fakeroot-1.19/wrapfunc.inp
++++ fakeroot-1.19/wrapfunc.inp
+@@ -206,12 +206,14 @@
+ #endif /* HAVE_UNLINKAT */
+ #endif /* HAVE_FSTATAT */
+
++#ifdef HAVE_SYS_ACL_H
+ #ifdef HAVE_ACL_T
+ acl_get_fd;acl_t;(int fd);(fd)
+ acl_get_file;acl_t;(const char *path_p, acl_type_t type);(path_p, type)
+ acl_set_fd;int;(int fd, acl_t acl);(fd, acl)
+ acl_set_file;int;(const char *path_p, acl_type_t type, acl_t acl);(path_p, type, acl)
+ #endif /* HAVE_ACL_T */
++#endif /* HAVE_SYS_ACL_H */
+
+ #ifdef HAVE_FTS_READ
+ fts_read;FTSENT *;(FTS *ftsp);(ftsp)