summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-02-02 01:35:39 +0000
committerMike Gilbert <floppym@gentoo.org>2012-02-02 01:35:39 +0000
commit58b90509c21be76b9f3b26c4f2beaa3c47d6ab29 (patch)
treea9e4154ecce898cf4824cd85ff7527b9367891d8 /sys-apps/file/file-5.09.ebuild
parentmedia-gfx/gimp: 2.6.12 (diff)
downloadgentoo-2-58b90509c21be76b9f3b26c4f2beaa3c47d6ab29.tar.gz
gentoo-2-58b90509c21be76b9f3b26c4f2beaa3c47d6ab29.tar.bz2
gentoo-2-58b90509c21be76b9f3b26c4f2beaa3c47d6ab29.zip
Inherit toolchain-funcs explicitly. Quote WORKDIR.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/file/file-5.09.ebuild')
-rw-r--r--sys-apps/file/file-5.09.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/file/file-5.09.ebuild b/sys-apps/file/file-5.09.ebuild
index ad99b904877d..46da2da1aeae 100644
--- a/sys-apps/file/file-5.09.ebuild
+++ b/sys-apps/file/file-5.09.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.09.ebuild,v 1.7 2011/12/31 08:28:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.09.ebuild,v 1.8 2012/02/02 01:35:39 floppym Exp $
EAPI="2"
PYTHON_DEPEND="python? *"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="*-jython"
-inherit eutils distutils libtool flag-o-matic
+inherit eutils distutils libtool flag-o-matic toolchain-funcs
DESCRIPTION="identify a file's format by scanning binary data for patterns"
HOMEPAGE="ftp://ftp.astron.com/pub/file/"
@@ -33,7 +33,7 @@ src_prepare() {
usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
-wd() { echo ${WORKDIR}/build-${CHOST}; }
+wd() { echo "${WORKDIR}"/build-${CHOST}; }
do_configure() {
ECONF_SOURCE=${S}