summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-28 20:51:09 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-28 20:51:09 +0000
commitbc16d2bea5c11e92655891ae72bab11ff847f3d1 (patch)
tree55a624874117eab274a43a4f9cd1c96235a38681 /sys-apps/file
parentold (diff)
downloadgentoo-2-bc16d2bea5c11e92655891ae72bab11ff847f3d1.tar.gz
gentoo-2-bc16d2bea5c11e92655891ae72bab11ff847f3d1.tar.bz2
gentoo-2-bc16d2bea5c11e92655891ae72bab11ff847f3d1.zip
Version bump.
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-4.23.ebuild58
-rw-r--r--sys-apps/file/files/digest-file-4.233
3 files changed, 67 insertions, 1 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index ddabde53b831..afbea0c00dd7 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.153 2007/12/27 18:34:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.154 2007/12/28 20:51:08 vapier Exp $
+
+*file-4.23 (28 Dec 2007)
+
+ 28 Dec 2007; Mike Frysinger <vapier@gentoo.org> +file-4.23.ebuild:
+ Version bump.
*file-4.22 (27 Dec 2007)
diff --git a/sys-apps/file/file-4.23.ebuild b/sys-apps/file/file-4.23.ebuild
new file mode 100644
index 000000000000..44b92b980d2c
--- /dev/null
+++ b/sys-apps/file/file-4.23.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.23.ebuild,v 1.1 2007/12/28 20:51:08 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/digest-file-4.23 b/sys-apps/file/files/digest-file-4.23
new file mode 100644
index 000000000000..680b921a45a4
--- /dev/null
+++ b/sys-apps/file/files/digest-file-4.23
@@ -0,0 +1,3 @@
+MD5 014a69979a8d5225a6ca2bcc4d7e967e file-4.23.tar.gz 563704
+RMD160 29153a3fb18b2d8f7da9fd66712fbd6ed4ea49f2 file-4.23.tar.gz 563704
+SHA256 2fad96e6475b7a67e1e96f05e825b779686fd0cb3f041a10ca6622a4d9f7d147 file-4.23.tar.gz 563704