summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-16 17:45:04 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-16 17:45:04 +0000
commitf25bdc763094ed5ce658c779631c00e97ddc5948 (patch)
tree52b94c851d11dbd1e8d3df636989895decf10b6b /sys-apps/findutils
parentmask newer udevs (diff)
downloadgentoo-2-f25bdc763094ed5ce658c779631c00e97ddc5948.tar.gz
gentoo-2-f25bdc763094ed5ce658c779631c00e97ddc5948.tar.bz2
gentoo-2-f25bdc763094ed5ce658c779631c00e97ddc5948.zip
query the toolchain to see if it supports regex.h
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/findutils-4.3.0.ebuild6
-rw-r--r--sys-apps/findutils/findutils-4.3.1-r1.ebuild6
-rw-r--r--sys-apps/findutils/findutils-4.3.1.ebuild6
3 files changed, 6 insertions, 12 deletions
diff --git a/sys-apps/findutils/findutils-4.3.0.ebuild b/sys-apps/findutils/findutils-4.3.0.ebuild
index 6d8a0ff18eba..3d9b6409ed9f 100644
--- a/sys-apps/findutils/findutils-4.3.0.ebuild
+++ b/sys-apps/findutils/findutils-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.17 2006/09/09 16:56:26 christel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.18 2006/11/16 17:45:04 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -48,9 +48,7 @@ src_compile() {
local myconf
use userland_GNU || myconf=" --program-prefix=g"
- if ([[ ${ELIBC} == "glibc" ]] && has_version '>=sys-libs/glibc-2.3') \
- || [[ ${ELIBC} == "uclibc" ]]
- then
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
myconf="${myconf} --without-included-regex"
fi
diff --git a/sys-apps/findutils/findutils-4.3.1-r1.ebuild b/sys-apps/findutils/findutils-4.3.1-r1.ebuild
index 078f18c9ed5c..27e5e3a9d792 100644
--- a/sys-apps/findutils/findutils-4.3.1-r1.ebuild
+++ b/sys-apps/findutils/findutils-4.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.1-r1.ebuild,v 1.2 2006/11/07 15:18:43 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.1-r1.ebuild,v 1.3 2006/11/16 17:45:04 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -47,9 +47,7 @@ src_compile() {
local myconf
use userland_GNU || myconf=" --program-prefix=g"
- if ([[ ${ELIBC} == "glibc" ]] && has_version '>=sys-libs/glibc-2.3') \
- || [[ ${ELIBC} == "uclibc" ]]
- then
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
myconf="${myconf} --without-included-regex"
fi
diff --git a/sys-apps/findutils/findutils-4.3.1.ebuild b/sys-apps/findutils/findutils-4.3.1.ebuild
index 7976322c28f7..cf776992e16b 100644
--- a/sys-apps/findutils/findutils-4.3.1.ebuild
+++ b/sys-apps/findutils/findutils-4.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.1.ebuild,v 1.2 2006/09/19 01:06:19 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.1.ebuild,v 1.3 2006/11/16 17:45:04 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -44,9 +44,7 @@ src_compile() {
local myconf
use userland_GNU || myconf=" --program-prefix=g"
- if ([[ ${ELIBC} == "glibc" ]] && has_version '>=sys-libs/glibc-2.3') \
- || [[ ${ELIBC} == "uclibc" ]]
- then
+ if echo "#include <regex.h>" | $(tc-getCPP) > /dev/null ; then
myconf="${myconf} --without-included-regex"
fi