summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-10 06:06:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-10 06:06:00 +0000
commit1b707194e9e82050831554195ed08290ea2ebbf2 (patch)
treeda2bdae6cb53e280834302365170d0bf3295f2bb /sys-apps/grep
parentversion bump (diff)
downloadgentoo-2-1b707194e9e82050831554195ed08290ea2ebbf2.tar.gz
gentoo-2-1b707194e9e82050831554195ed08290ea2ebbf2.tar.bz2
gentoo-2-1b707194e9e82050831554195ed08290ea2ebbf2.zip
Version bump.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/ChangeLog7
-rw-r--r--sys-apps/grep/grep-2.5.4.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-apps/grep/ChangeLog b/sys-apps/grep/ChangeLog
index b608c4bdb83c..0d08bd1b6477 100644
--- a/sys-apps/grep/ChangeLog
+++ b/sys-apps/grep/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/grep
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.80 2009/01/04 21:07:46 the_paya Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/ChangeLog,v 1.81 2009/02/10 06:06:00 vapier Exp $
+
+*grep-2.5.4 (10 Feb 2009)
+
+ 10 Feb 2009; Mike Frysinger <vapier@gentoo.org> +grep-2.5.4.ebuild:
+ Version bump.
04 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+files/grep-2.5.3-nls.patch, grep-2.5.3-r1.ebuild:
diff --git a/sys-apps/grep/grep-2.5.4.ebuild b/sys-apps/grep/grep-2.5.4.ebuild
new file mode 100644
index 000000000000..6a6c7b1fbc73
--- /dev/null
+++ b/sys-apps/grep/grep-2.5.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.5.4.ebuild,v 1.1 2009/02/10 06:06:00 vapier Exp $
+
+DESCRIPTION="GNU regular expression matcher"
+HOMEPAGE="http://www.gnu.org/software/grep/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls pcre static"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ pcre? ( dev-libs/libpcre )
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf \
+ --bindir=/bin \
+ $(use_enable nls) \
+ $(use_enable pcre perl-regexp) \
+ $(use elibc_FreeBSD || echo --without-included-regex) \
+ || die "econf failed"
+
+ use static || sed -i 's:-lpcre:-Wl,-Bstatic -lpcre -Wl,-Bdynamic:g' src/Makefile
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}