summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-24 18:59:33 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-24 18:59:33 +0000
commit295de4444f6a5f1adc046facaf79762c8d2c3c39 (patch)
tree89aa5c2f33e71d6b061ce2b80d62bd0205e4db0d /sys-apps/groff
parentversion bump (diff)
downloadgentoo-2-295de4444f6a5f1adc046facaf79762c8d2c3c39.tar.gz
gentoo-2-295de4444f6a5f1adc046facaf79762c8d2c3c39.tar.bz2
gentoo-2-295de4444f6a5f1adc046facaf79762c8d2c3c39.zip
Make sure we forces dashes in unicode to the traditional "-" so that users dont get confused by the pretty looking versions #121502.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog11
-rw-r--r--sys-apps/groff/files/groff-1.19.2-man-unicode-dashes.patch24
-rw-r--r--sys-apps/groff/groff-1.19.2-r2.ebuild82
3 files changed, 115 insertions, 2 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index 9b39933c096e..ed0dbc7b59e7 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/groff
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.78 2006/12/30 13:44:18 usata Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.79 2008/02/24 18:59:32 vapier Exp $
+
+*groff-1.19.2-r2 (24 Feb 2008)
+
+ 24 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/groff-1.19.2-man-unicode-dashes.patch, +groff-1.19.2-r2.ebuild:
+ Make sure we forces dashes in unicode to the traditional "-" so that users
+ dont get confused by the pretty looking versions #121502.
30 Dec 2006; Mamoru KOMACHI <usata@gentoo.org> groff-1.19.2-r1.ebuild:
Added eautoreconf and --enable-japanese in order to get cjk patch working
diff --git a/sys-apps/groff/files/groff-1.19.2-man-unicode-dashes.patch b/sys-apps/groff/files/groff-1.19.2-man-unicode-dashes.patch
new file mode 100644
index 000000000000..d85a8330d274
--- /dev/null
+++ b/sys-apps/groff/files/groff-1.19.2-man-unicode-dashes.patch
@@ -0,0 +1,24 @@
+format dashes as dashes so as to not confuse people
+
+http://bugs.gentoo.org/16108
+http://bugs.gentoo.org/17580
+http://bugs.gentoo.org/121502
+
+--- tmac/man.local
++++ tmac/man.local
+@@ -1,2 +1,6 @@
+ .\" This file is loaded after an-old.tmac.
+ .\" Put any local modifications to an-old.tmac here.
++.if '\*[.T]'utf8' \{\
++. char \- \N'45'
++. char - \N'45'
++.\}
+--- tmac/mdoc.local
++++ tmac/mdoc.local
+@@ -1,2 +1,6 @@
+ .\" This file is loaded after doc.tmac.
+ .\" Put any local modifications to doc.tmac here.
++.if '\*[.T]'utf8' \{\
++. char \- \N'45'
++. char - \N'45'
++.\}
diff --git a/sys-apps/groff/groff-1.19.2-r2.ebuild b/sys-apps/groff/groff-1.19.2-r2.ebuild
new file mode 100644
index 000000000000..3d4b061b22b0
--- /dev/null
+++ b/sys-apps/groff/groff-1.19.2-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.19.2-r2.ebuild,v 1.1 2008/02/24 18:59:32 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib autotools
+
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz
+ cjk? ( mirror://gentoo/groff-1.19.2-japanese.patch.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk X"
+
+DEPEND=">=sys-apps/texinfo-4.7-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the info pages to have .info extensions,
+ # else they do not get gzipped.
+ epatch "${FILESDIR}"/${P}-infoext.patch
+
+ epatch "${FILESDIR}"/${P}-man-unicode-dashes.patch #16108 #17580 #121502
+ epatch "${FILESDIR}"/${P}-parallel-make.patch
+
+ # Make sure we can cross-compile this puppy
+ if tc-is-cross-compiler ; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=/usr/bin/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=/usr/bin/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
+ contrib/mom/Makefile.sub \
+ doc/Makefile.in \
+ doc/Makefile.sub || die "cross-compile sed failed"
+ fi
+
+ if use cjk ; then
+ epatch "${WORKDIR}"/groff-1.19.2-japanese.patch #134377
+ eautoreconf
+ fi
+}
+
+src_compile() {
+ # Fix problems with not finding g++
+ tc-export CC CXX
+
+ # -Os causes segfaults, -O is probably a fine replacement
+ # (fixes bug 36008, 06 Jan 2004 agriffis)
+ replace-flags -Os -O
+
+ econf \
+ --with-appresdir=/etc/X11/app-defaults \
+ $(use_with X x) \
+ $(use_enable cjk japanese) \
+ || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make \
+ prefix="${D}"/usr \
+ bindir="${D}"/usr/bin \
+ libdir="${D}"/usr/$(get_libdir) \
+ appresdir="${D}"/etc/X11/app-defaults \
+ datadir="${D}"/usr/share \
+ mandir="${D}"/usr/share/man \
+ infodir="${D}"/usr/share/info \
+ docdir="${D}"/usr/share/doc/${PF} \
+ install || die
+
+ # The following links are required for man #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ dodoc BUG-REPORT ChangeLog FDL MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+}