summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-01-03 21:05:04 +0000
committerMike Frysinger <vapier@gentoo.org>2011-01-03 21:05:04 +0000
commit5ec3e0d5d0ab0a340fb65bb35a5acc89ec123861 (patch)
tree51b45f8565312a27c9f21f81b8eb4f3fa0433041 /sys-apps/groff
parentVersion bump; remove old (diff)
downloadgentoo-2-5ec3e0d5d0ab0a340fb65bb35a5acc89ec123861.tar.gz
gentoo-2-5ec3e0d5d0ab0a340fb65bb35a5acc89ec123861.tar.bz2
gentoo-2-5ec3e0d5d0ab0a340fb65bb35a5acc89ec123861.zip
Version bump #350443 by Panagiotis Christopoulos.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/groff')
-rw-r--r--sys-apps/groff/ChangeLog9
-rw-r--r--sys-apps/groff/groff-1.21.ebuild78
2 files changed, 85 insertions, 2 deletions
diff --git a/sys-apps/groff/ChangeLog b/sys-apps/groff/ChangeLog
index d440272626bb..6c9744f12160 100644
--- a/sys-apps/groff/ChangeLog
+++ b/sys-apps/groff/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/groff
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.105 2010/07/25 21:29:44 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/ChangeLog,v 1.106 2011/01/03 21:05:04 vapier Exp $
+
+*groff-1.21 (03 Jan 2011)
+
+ 03 Jan 2011; Mike Frysinger <vapier@gentoo.org> +groff-1.21.ebuild:
+ Version bump #350443 by Panagiotis Christopoulos.
25 Jul 2010; Jeroen Roovers <jer@gentoo.org> groff-1.20.1-r3.ebuild:
Fix patch name thanks to Bobby Bingham (bug #329819).
diff --git a/sys-apps/groff/groff-1.21.ebuild b/sys-apps/groff/groff-1.21.ebuild
new file mode 100644
index 000000000000..be2024cb2eaa
--- /dev/null
+++ b/sys-apps/groff/groff-1.21.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/groff/groff-1.21.ebuild,v 1.1 2011/01/03 21:05:04 vapier Exp $
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Text formatter used for man pages"
+HOMEPAGE="http://www.gnu.org/software/groff/groff.html"
+SRC_URI="mirror://gnu/groff/${P}.tar.gz
+ linguas_ja? ( mirror://gentoo/${PN}-1.20.1-r2-japanese.patch.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples X linguas_ja"
+
+DEPEND=">=sys-apps/texinfo-4.7-r1
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXaw
+ x11-libs/libSM
+ x11-libs/libICE
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.19.2-man-unicode-dashes.patch #16108 #17580 #121502
+
+ # Make sure we can cross-compile this puppy
+ if tc-is-cross-compiler ; then
+ sed -i \
+ -e '/^GROFFBIN=/s:=.*:=/usr/bin/groff:' \
+ -e '/^TROFFBIN=/s:=.*:=/usr/bin/troff:' \
+ -e '/^GROFF_BIN_PATH=/s:=.*:=:' \
+ -e '/^GROFF_BIN_DIR=/s:=.*:=:' \
+ contrib/*/Makefile.sub \
+ doc/Makefile.in \
+ doc/Makefile.sub || die "cross-compile sed failed"
+ fi
+
+ cat <<-EOF >> tmac/mdoc.local
+ .ds volume-operating-system Gentoo
+ .ds operating-system Gentoo/${KERNEL}
+ .ds default-operating-system Gentoo/${KERNEL}
+ EOF
+
+ if use linguas_ja ; then
+ epatch "${WORKDIR}"/${PN}-1.20.1-r2-japanese.patch #255292
+ eautoconf
+ eautoheader
+ fi
+}
+
+src_compile() {
+ econf \
+ --with-appresdir=/usr/share/X11/app-defaults \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use linguas_ja && echo --enable-japanese)
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # The following links are required for man #123674
+ dosym eqn /usr/bin/geqn
+ dosym tbl /usr/bin/gtbl
+
+ dodoc BUG-REPORT ChangeLog MORE.STUFF NEWS \
+ PROBLEMS PROJECTS README REVISION TODO VERSION
+
+ use examples || rm -rf "${D}"/usr/share/doc/${PF}/examples
+}