summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-01-23 19:24:48 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-01-23 19:24:48 +0000
commit044d362c640f91d52e79740a21a75ee8eb6656ec (patch)
tree33a807e13c59ac8c09aa7e3822c312471033b524 /sys-apps/hotplug
parentAdd new Version 0.6.4. (diff)
downloadgentoo-2-044d362c640f91d52e79740a21a75ee8eb6656ec.tar.gz
gentoo-2-044d362c640f91d52e79740a21a75ee8eb6656ec.tar.bz2
gentoo-2-044d362c640f91d52e79740a21a75ee8eb6656ec.zip
Updated hotplug.rc.empty to unpack firmware tarball. This is used by the LiveCD to allow /lib/firmware to be tmpfs without losing any firmwares that were installed on the LiveCD and allows users to provide their own firmwares.
(Portage version: 2.0.51-r14)
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/ChangeLog9
-rw-r--r--sys-apps/hotplug/files/hotplug.rc.empty9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-apps/hotplug/ChangeLog b/sys-apps/hotplug/ChangeLog
index 26091413b6ea..4df67132eee2 100644
--- a/sys-apps/hotplug/ChangeLog
+++ b/sys-apps/hotplug/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/hotplug
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.60 2005/01/21 21:07:02 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/ChangeLog,v 1.61 2005/01/23 19:24:48 wolf31o2 Exp $
+
+ 23 Jan 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/hotplug.rc.empty:
+ Updated hotplug.rc.empty to unpack firmware tarball. This is used by the
+ LiveCD to allow /lib/firmware to be tmpfs without losing any firmwares that
+ were installed on the LiveCD and allows users to provide their own
+ firmwares.
21 Jan 2005; Lars Weiler <pylon@gentoo.org> hotplug-20040923.ebuild:
Stable on ppc.
diff --git a/sys-apps/hotplug/files/hotplug.rc.empty b/sys-apps/hotplug/files/hotplug.rc.empty
index 451e641a0b65..abb01fcd8429 100644
--- a/sys-apps/hotplug/files/hotplug.rc.empty
+++ b/sys-apps/hotplug/files/hotplug.rc.empty
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc.empty,v 1.1 2004/09/21 00:13:47 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/files/hotplug.rc.empty,v 1.2 2005/01/23 19:24:48 wolf31o2 Exp $
#
# nothing here anymore. Please use the coldplug package if you really want to
@@ -24,4 +24,11 @@ start () {
eerror "CONFIG_HOTPLUG not enabled for this kernel!"
return 1
fi
+ # This unpacks any firmware tarballs. Used for LiveCD.
+ if [ -e /lib/firmware.tar.bz2 ]
+ then
+ ebegin "Unpacking hotplug frmware"
+ tar xjf /lib/firmware.tar.bz2 -C /lib/firmware
+ eend 0
+ fi
}