summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-02 06:42:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-12-02 06:42:35 +0000
commit5d60c7b00f21e2fc783438e31e18619ce6936e07 (patch)
tree2ad6ac956679d4a981bc0eaae8dba8f1ba129467 /sys-apps/hwids/hwids-99999999.ebuild
parentInherit autotools eclass (bug #445526). (diff)
downloadgentoo-2-5d60c7b00f21e2fc783438e31e18619ce6936e07.tar.gz
gentoo-2-5d60c7b00f21e2fc783438e31e18619ce6936e07.tar.bz2
gentoo-2-5d60c7b00f21e2fc783438e31e18619ce6936e07.zip
Now install oui.txt as well (due to udev/bluez requirements).
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key D4301342)
Diffstat (limited to 'sys-apps/hwids/hwids-99999999.ebuild')
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index e7c06eca2db8..6ef92b93cd0b 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.2 2012/06/16 12:51:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.3 2012/12/02 06:42:35 flameeyes Exp $
EAPI="4"
DESCRIPTION="Hardware (PCI, USB) IDs databases"
HOMEPAGE="https://github.com/gentoo/hwids"
-LICENSE="|| ( GPL-2 BSD )"
+# freedist is for oui.txt, and it's mostly wishful thinking
+LICENSE="|| ( GPL-2 BSD ) freedist"
SLOT="0"
KEYWORDS=""
IUSE=""
@@ -19,7 +20,7 @@ RDEPEND="!<sys-apps/pciutils-3.1.9-r2
!<sys-apps/usbutils-005-r1"
src_compile() {
- wget http://pci-ids.ucw.cz/v2.2/pci.ids.gz http://www.linux-usb.org/usb.ids.gz || die
+ wget http://pci-ids.ucw.cz/v2.2/pci.ids.gz http://www.linux-usb.org/usb.ids.gz http://standards.ieee.org/develop/regauth/oui/oui.txt || die
for file in {usb,pci}.ids; do
zcat ${file}.gz > ${file} || die
@@ -28,5 +29,5 @@ src_compile() {
src_install() {
insinto /usr/share/misc
- doins {usb,pci}.ids{,.gz}
+ doins {usb,pci}.ids{,.gz} oid.txt
}