summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 14:21:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-09 14:21:46 +0000
commit821661bd0f288064ece47562179f8529bd716fb9 (patch)
treeade56329a71ee2a098a0eae94c659a4e0458739a /sys-apps/hwids
parentStable for ia64, wrt bug #459158 (diff)
downloadgentoo-2-821661bd0f288064ece47562179f8529bd716fb9.tar.gz
gentoo-2-821661bd0f288064ece47562179f8529bd716fb9.tar.bz2
gentoo-2-821661bd0f288064ece47562179f8529bd716fb9.zip
Version bump.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-apps/hwids')
-rw-r--r--sys-apps/hwids/ChangeLog7
-rw-r--r--sys-apps/hwids/hwids-20130309.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-apps/hwids/ChangeLog b/sys-apps/hwids/ChangeLog
index a1014268b5b0..6f1b2e00f16f 100644
--- a/sys-apps/hwids/ChangeLog
+++ b/sys-apps/hwids/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/hwids
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.89 2013/03/07 16:12:51 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/ChangeLog,v 1.90 2013/03/09 14:21:46 flameeyes Exp $
+
+*hwids-20130309 (09 Mar 2013)
+
+ 09 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org> +hwids-20130309.ebuild:
+ Version bump.
07 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org> -hwids-20130114.ebuild:
Remove old.
diff --git a/sys-apps/hwids/hwids-20130309.ebuild b/sys-apps/hwids/hwids-20130309.ebuild
new file mode 100644
index 000000000000..627cf2893e38
--- /dev/null
+++ b/sys-apps/hwids/hwids-20130309.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20130309.ebuild,v 1.1 2013/03/09 14:21:46 flameeyes Exp $
+
+EAPI=5
+inherit udev eutils
+
+DESCRIPTION="Hardware (PCI, USB, OUI, IAB) IDs databases"
+HOMEPAGE="https://github.com/gentoo/hwids"
+SRC_URI="https://github.com/gentoo/hwids/archive/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 BSD ) public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="+udev"
+
+DEPEND="udev? (
+ dev-lang/perl
+ >=virtual/udev-197-r1
+)"
+RDEPEND="!<sys-apps/pciutils-3.1.9-r2
+ !<sys-apps/usbutils-005-r1"
+
+S=${WORKDIR}/hwids-${P}
+
+src_compile() {
+ emake UDEV=$(usex udev)
+}
+
+src_install() {
+ emake UDEV=$(usex udev) install \
+ DOCDIR="${EPREFIX}/usr/share/doc/${PF}" \
+ MISCDIR="${EPREFIX}/usr/share/misc" \
+ HWDBDIR="${EPREFIX}$(udev_get_udevdir)/hwdb.d" \
+ DESTDIR="${D}"
+}