summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-02-18 06:48:29 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-02-18 06:48:29 +0000
commit06653dedf4851b4edbd365414999fa44befee447 (patch)
tree318b65477c9546c8803340312299800e428c86bc /sys-apps/hwloc/hwloc-1.4.2.ebuild
parentVersion bump (diff)
downloadgentoo-2-06653dedf4851b4edbd365414999fa44befee447.tar.gz
gentoo-2-06653dedf4851b4edbd365414999fa44befee447.tar.bz2
gentoo-2-06653dedf4851b4edbd365414999fa44befee447.zip
Restore last available version from 1.4 branch as it is required for sys-cluster/mpich2-1.4.1_p1. Thanks to Michael Sterrett <mr_bones_@gentoo.org> for cathing this
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sys-apps/hwloc/hwloc-1.4.2.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-1.4.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/hwloc/hwloc-1.4.2.ebuild b/sys-apps/hwloc/hwloc-1.4.2.ebuild
new file mode 100644
index 000000000000..7acc7b2a1574
--- /dev/null
+++ b/sys-apps/hwloc/hwloc-1.4.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.4.2.ebuild,v 1.4 2013/02/18 06:48:29 xarthisius Exp $
+
+EAPI=4
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
+
+DESCRIPTION="displays the hardware topology in convenient formats"
+HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="cairo debug +numa +pci svg static-libs xml X"
+
+RDEPEND="sys-libs/ncurses
+ cairo? ( x11-libs/cairo[X?,svg?] )
+ pci? ( sys-apps/pciutils )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ numa? ( sys-process/numactl )"
+
+DOCS=( AUTHORS NEWS README VERSION )
+
+src_configure() {
+ export HWLOC_PKG_CONFIG=$(tc-getPKG_CONFIG) #393467
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable cairo) \
+ $(use_enable debug) \
+ $(use_enable pci) \
+ $(use_enable numa libnuma) \
+ $(use_enable static-libs static) \
+ $(use_enable xml libxml2) \
+ $(use_with X x) \
+ --disable-silent-rules
+}
+
+src_install() {
+ default
+ use static-libs || rm "${D}"/usr/$(get_libdir)/lib${PN}.la
+}