summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2011-08-02 05:21:19 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2011-08-02 05:21:19 +0000
commite005d7529e361b42974a9797545481bfce94cbd7 (patch)
tree7d6701f4aadd3377a1124129c308d0e4f637855c /sys-apps/hwloc
parentSplit long line. Use autotools-utils eclass instead of find. (diff)
downloadgentoo-2-e005d7529e361b42974a9797545481bfce94cbd7.tar.gz
gentoo-2-e005d7529e361b42974a9797545481bfce94cbd7.tar.bz2
gentoo-2-e005d7529e361b42974a9797545481bfce94cbd7.zip
Version bump, drop old
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/hwloc')
-rw-r--r--sys-apps/hwloc/ChangeLog8
-rw-r--r--sys-apps/hwloc/hwloc-1.0.3.ebuild35
-rw-r--r--sys-apps/hwloc/hwloc-1.2.ebuild (renamed from sys-apps/hwloc/hwloc-1.1.1.ebuild)25
3 files changed, 19 insertions, 49 deletions
diff --git a/sys-apps/hwloc/ChangeLog b/sys-apps/hwloc/ChangeLog
index ae795b29aac1..5eb1ef306b49 100644
--- a/sys-apps/hwloc/ChangeLog
+++ b/sys-apps/hwloc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/hwloc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.9 2011/07/10 16:23:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/ChangeLog,v 1.10 2011/08/02 05:21:19 xarthisius Exp $
+
+*hwloc-1.2 (02 Aug 2011)
+
+ 02 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> -hwloc-1.0.3.ebuild,
+ -hwloc-1.1.1.ebuild, +hwloc-1.2.ebuild:
+ Version bump, drop old
10 Jul 2011; Alexis Ballier <aballier@gentoo.org> hwloc-1.1.1-r1.ebuild:
keyword ~x86-fbsd, bug #372885
diff --git a/sys-apps/hwloc/hwloc-1.0.3.ebuild b/sys-apps/hwloc/hwloc-1.0.3.ebuild
deleted file mode 100644
index eddc075c2735..000000000000
--- a/sys-apps/hwloc/hwloc-1.0.3.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.0.3.ebuild,v 1.2 2011/01/24 16:14:03 xarthisius Exp $
-
-EAPI=2
-
-inherit autotools-utils
-
-DESCRIPTION="displays the hardware topology in convenient formats"
-HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
-SRC_URI="http://www.open-mpi.org/software/hwloc/v1.0/downloads/${P}.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="cairo svg static-libs xml X"
-SLOT="0"
-LICENSE="BSD"
-
-RDEPEND="sys-libs/ncurses
- cairo? ( x11-libs/cairo[X?,svg?] )
- xml? ( dev-libs/libxml2 )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-DOCS=( AUTHORS NEWS README VERSION )
-
-src_configure() {
- myeconfargs=(
- $(use_enable cairo)
- $(use_enable static-libs static)
- $(use_enable xml)
- $(use_with X x)
- --disable-silent-rules
- )
- autotools-utils_src_configure
-}
diff --git a/sys-apps/hwloc/hwloc-1.1.1.ebuild b/sys-apps/hwloc/hwloc-1.2.ebuild
index 7582f2f4e2c1..9a72345557ee 100644
--- a/sys-apps/hwloc/hwloc-1.1.1.ebuild
+++ b/sys-apps/hwloc/hwloc-1.2.ebuild
@@ -1,14 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.1.1.ebuild,v 1.1 2011/01/26 19:43:12 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwloc/hwloc-1.2.ebuild,v 1.1 2011/08/02 05:21:19 xarthisius Exp $
-EAPI=2
+EAPI="4"
+
+inherit multilib versionator
+
+MY_PV=v$(get_version_component_range 1-2)
DESCRIPTION="displays the hardware topology in convenient formats"
HOMEPAGE="http://www.open-mpi.org/projects/hwloc/"
-SRC_URI="http://www.open-mpi.org/software/hwloc/v1.1/downloads/${P}.tar.bz2"
+SRC_URI="http://www.open-mpi.org/software/${PN}/${MY_PV}/downloads/${P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux"
IUSE="cairo svg static-libs xml X"
SLOT="0"
LICENSE="BSD"
@@ -21,7 +25,7 @@ DEPEND="${RDEPEND}
src_configure() {
econf \
- --docdir=/usr/share/doc/${P} \
+ --docdir="${EPREFIX}/usr/share/doc/${P}" \
$(use_enable cairo) \
$(use_enable static-libs static) \
$(use_enable xml) \
@@ -30,12 +34,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS NEWS README VERSION || die
-}
-
-src_test() {
- # autotools-utils broke tests, the first of which being
- # PASS: 256ppc-8n8s4t-nosys.output
- emake check || die
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README VERSION
+ use static-libs || rm /usr/$(get_libdir)/lib${PN}.la
}