summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-07 19:06:43 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-07 19:06:43 +0000
commit5db834ffc9c39fe778d42e2f5987cb88ed507165 (patch)
tree308c912304d2b6e0565e817f90febc65f0727025 /sys-apps/hwsetup/hwsetup-1.2.ebuild
parentVersion bump. (diff)
downloadgentoo-2-5db834ffc9c39fe778d42e2f5987cb88ed507165.tar.gz
gentoo-2-5db834ffc9c39fe778d42e2f5987cb88ed507165.tar.bz2
gentoo-2-5db834ffc9c39fe778d42e2f5987cb88ed507165.zip
Fix compilation when using --as-needed by filtering it, for now.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-apps/hwsetup/hwsetup-1.2.ebuild')
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/hwsetup/hwsetup-1.2.ebuild b/sys-apps/hwsetup/hwsetup-1.2.ebuild
index 2346483ee5da..069dcac8e391 100644
--- a/sys-apps/hwsetup/hwsetup-1.2.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2.ebuild,v 1.6 2008/02/20 20:32:27 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2.ebuild,v 1.7 2008/03/07 19:06:43 wolf31o2 Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -30,6 +30,8 @@ src_unpack() {
}
src_compile() {
+ append-ldflags -s
+ filter-ldflags -Wl,--as-needed --as-needed
if use zlib
then
append-ldflags -lz
@@ -43,3 +45,10 @@ src_compile() {
src_install() {
einstall DESTDIR="${D}" PREFIX=/usr MANDIR=/usr/share/man || die "Install failed"
}
+
+pkg_postinst() {
+ ewarn "This package is intended for usage on the Gentoo release media. If"
+ ewarn "you are not building a CD, remove this package. It will not work"
+ ewarn "properly on a running system, as Gentoo does not use any of the"
+ ewarn "Knoppix-style detection except for CD builds."
+}