summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 17:13:29 +0000
commite52924ccac137516e6e5fd1f3ae9203f8791f898 (patch)
treebe8b1bd2b96be49707d29aea3dd968602f1cc854 /sys-apps/ipchains
parentfixums (diff)
downloadgentoo-2-e52924ccac137516e6e5fd1f3ae9203f8791f898.tar.gz
gentoo-2-e52924ccac137516e6e5fd1f3ae9203f8791f898.tar.bz2
gentoo-2-e52924ccac137516e6e5fd1f3ae9203f8791f898.zip
fixums
Diffstat (limited to 'sys-apps/ipchains')
-rw-r--r--sys-apps/ipchains/ipchains-1.3.10-r1.ebuild47
1 files changed, 20 insertions, 27 deletions
diff --git a/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
index 916a2313b31e..5345e89955e9 100644
--- a/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
+++ b/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild
@@ -1,43 +1,36 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild,v 1.1 2001/02/07 15:51:27 achim Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ipchains/ipchains-1.3.10-r1.ebuild,v 1.2 2001/10/06 17:13:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="2.2 kernel equivalent of ipfwadm"
-SRC_URI="http://netfilter.kernelnotes.org/ipchains/${A}"
+DESCRIPTION="legacy Linux firewall/packet mangling tools"
+SRC_URI="http://netfilter.kernelnotes.org/ipchains/${P}.tar.gz"
HOMEPAGE="http://netfilter.filewatcher.org/ipchains/"
-
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
- cd ${S}
- mv Makefile Makefile.orig
- sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
- cd ${S}/libipfwc
- mv Makefile Makefile.orig
- sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+ unpack ${A}
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/libipfwc
+ mv Makefile Makefile.orig
+ sed -e "s/= -g -O/= ${CFLAGS}/" Makefile.orig > Makefile
}
src_compile() {
-
- try make clean
- try make ${MAKEOPTS} all
-
+ make clean || die
+ emake all || die
}
src_install() {
-
- into /
- dosbin ipchains
- doman ipfw.4 ipchains.8
- dodoc COPYING README
- docinto ps
- dodoc ipchains-quickref.ps
-
+ into /
+ dosbin ipchains
+ doman ipfw.4 ipchains.8
+ dodoc COPYING README
+ docinto ps
+ dodoc ipchains-quickref.ps
}