summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-25 04:33:05 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-25 04:33:05 +0000
commit34cba6f7434aef090f163e09424ebaec1c5ee34f (patch)
tree263d069dc711205679c5116a3d6f91acea98f247 /sys-apps/keyutils
parentBuild with -fno-strict-overflow. FreeBSD time code depends on overflow. #324452 (diff)
downloadgentoo-2-34cba6f7434aef090f163e09424ebaec1c5ee34f.tar.gz
gentoo-2-34cba6f7434aef090f163e09424ebaec1c5ee34f.tar.bz2
gentoo-2-34cba6f7434aef090f163e09424ebaec1c5ee34f.zip
Make the tests work reliably #405293 by Patrick Lauer.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/keyutils')
-rw-r--r--sys-apps/keyutils/ChangeLog5
-rw-r--r--sys-apps/keyutils/keyutils-1.5.5.ebuild22
2 files changed, 25 insertions, 2 deletions
diff --git a/sys-apps/keyutils/ChangeLog b/sys-apps/keyutils/ChangeLog
index 026b15d76e15..abba31de7c92 100644
--- a/sys-apps/keyutils/ChangeLog
+++ b/sys-apps/keyutils/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/keyutils
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/ChangeLog,v 1.27 2012/02/21 08:14:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/ChangeLog,v 1.28 2012/05/25 04:33:05 vapier Exp $
+
+ 25 May 2012; Mike Frysinger <vapier@gentoo.org> keyutils-1.5.5.ebuild:
+ Make the tests work reliably #405293 by Patrick Lauer.
*keyutils-1.5.5 (21 Feb 2012)
diff --git a/sys-apps/keyutils/keyutils-1.5.5.ebuild b/sys-apps/keyutils/keyutils-1.5.5.ebuild
index 3d4dd960f81d..6459b9b2d427 100644
--- a/sys-apps/keyutils/keyutils-1.5.5.ebuild
+++ b/sys-apps/keyutils/keyutils-1.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.1 2012/02/21 08:14:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/keyutils/keyutils-1.5.5.ebuild,v 1.2 2012/05/25 04:33:05 vapier Exp $
EAPI="3"
@@ -27,12 +27,32 @@ src_prepare() {
-e "/^LIBDIR/s:=.*:=/usr/$(get_libdir):" \
-e '/^USRLIBDIR/s:=.*:=$(LIBDIR):' \
Makefile || die
+
+ # The lsb check is useless, so avoid spurious command not found messages.
+ sed -i -e 's,lsb_release,:,' tests/prepare.inc.sh || die
+ # All the test files are bash, but try to execute via `sh`.
+ sed -i -r \
+ -e 's:([[:space:]])sh([[:space:]]):\1bash\2:' \
+ tests/{Makefile*,*.sh} || die
+ find tests/ -name '*.sh' -exec sed -i '1s:/sh$:/bash:' {} +
+ # Some tests call the kernel which calls userspace, but that will
+ # run the install keyutils rather than the locally compiled one,
+ # so disable round trip tests.
+ rm -rf tests/keyctl/requesting/{bad-args,piped,valid}
}
src_configure() {
tc-export CC
}
+src_test() {
+ # Execute the locally compiled code rather than the
+ # older versions already installed in the system.
+ LD_LIBRARY_PATH=${S} \
+ PATH="${S}:${PATH}" \
+ emake test || die
+}
+
src_install() {
emake DESTDIR="${ED}" install || die
dodoc README