summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2012-07-23 14:20:12 +0000
committerWilliam Hubbs <williamh@gentoo.org>2012-07-23 14:20:12 +0000
commit1ab9d8d0e207fc8b502a63d156d6ccd09668e51b (patch)
treefe9454743948750d97d36f987ba58bd2ef615851 /sys-apps/kmod
parentAdd Khmer. (diff)
downloadgentoo-2-1ab9d8d0e207fc8b502a63d156d6ccd09668e51b.tar.gz
gentoo-2-1ab9d8d0e207fc8b502a63d156d6ccd09668e51b.tar.bz2
gentoo-2-1ab9d8d0e207fc8b502a63d156d6ccd09668e51b.zip
remove old versions
(Portage version: 2.2.0_alpha118/cvs/Linux i686)
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/ChangeLog6
-rw-r--r--sys-apps/kmod/kmod-7.ebuild89
-rw-r--r--sys-apps/kmod/kmod-8.ebuild87
-rw-r--r--sys-apps/kmod/kmod-9.ebuild86
4 files changed, 5 insertions, 263 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index 9dca27b1f050..5715bdbce699 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,5 +1,9 @@
# ChangeLog for sys-apps/kmod
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.47 2012/07/22 17:24:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.48 2012/07/23 14:20:12 williamh Exp $
+
+ 23 Jul 2012; William Hubbs <williamh@gentoo.org> -kmod-7.ebuild,
+ -kmod-8.ebuild, -kmod-9.ebuild:
+ remove old versions
22 Jul 2012; Raúl Porcel <armin76@gentoo.org> kmod-9.ebuild,
kmod-9-r3.ebuild:
diff --git a/sys-apps/kmod/kmod-7.ebuild b/sys-apps/kmod/kmod-7.ebuild
deleted file mode 100644
index 63b4ee721348..000000000000
--- a/sys-apps/kmod/kmod-7.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-7.ebuild,v 1.11 2012/05/23 23:12:45 vapier Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
-
-[[ ${PV} == 9999 ]] && vcs=git-2
-inherit ${vcs} autotools eutils toolchain-funcs libtool
-unset vcs
-
-if [[ ${PV} != 9999 ]] ; then
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma static-libs +tools zlib"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- zlib? ( virtual/pkgconfig )"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-src_prepare()
-{
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure()
-{
- # http://bugs.gentoo.org/410865
- if has_version '<sys-libs/zlib-1.2.6'; then
- export zlib_CFLAGS="-I/usr/include"
- export zlib_LIBS="-lz"
- fi
-
- local myconf
- [[ ${PV} == 9999 ]] && myconf="$(use_enable doc gtk-doc)"
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable tools) \
- $(use_enable debug) \
- $(use_with lzma xz) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install()
-{
- default
-
- find "${D}" -name libkmod.la -exec rm -f {} +
-
- if use tools; then
- dodir /bin
- dosym /usr/bin/kmod /bin/lsmod
- dodir /sbin
- local cmd
- for cmd in depmod insmod modinfo modprobe rmmod; do
- dosym /usr/bin/kmod /sbin/${cmd}
- done
- fi
-}
diff --git a/sys-apps/kmod/kmod-8.ebuild b/sys-apps/kmod/kmod-8.ebuild
deleted file mode 100644
index a66fd98e3ce0..000000000000
--- a/sys-apps/kmod/kmod-8.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-8.ebuild,v 1.5 2012/06/13 15:46:09 vapier Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
-
-[[ ${PV} == 9999 ]] && vcs=git-2
-inherit ${vcs} autotools eutils toolchain-funcs libtool
-unset vcs
-
-if [[ ${PV} != 9999 ]] ; then
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma static-libs +tools zlib"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- zlib? ( virtual/pkgconfig )"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-src_prepare()
-{
- epatch "${FILESDIR}"/${P}-gc-sections.patch
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure()
-{
- # http://bugs.gentoo.org/410865
- if has_version '<sys-libs/zlib-1.2.6'; then
- export zlib_CFLAGS="-I/usr/include"
- export zlib_LIBS="-lz"
- fi
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable tools) \
- $(use_enable debug) \
- $(use_enable doc gtk-doc) \
- $(use_with lzma xz) \
- $(use_with zlib)
-}
-
-src_install()
-{
- default
-
- find "${D}" -name libkmod.la -exec rm -f {} +
-
- if use tools; then
- dodir /bin
- dosym /usr/bin/kmod /bin/lsmod
- dodir /sbin
- local cmd
- for cmd in depmod insmod modinfo modprobe rmmod; do
- dosym /usr/bin/kmod /sbin/${cmd}
- done
- fi
-}
diff --git a/sys-apps/kmod/kmod-9.ebuild b/sys-apps/kmod/kmod-9.ebuild
deleted file mode 100644
index fe930e62d521..000000000000
--- a/sys-apps/kmod/kmod-9.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9.ebuild,v 1.2 2012/07/22 17:24:06 armin76 Exp $
-
-EAPI=4
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
-
-[[ ${PV} == 9999 ]] && vcs=git-2
-inherit ${vcs} autotools eutils toolchain-funcs libtool
-unset vcs
-
-if [[ ${PV} != 9999 ]] ; then
- SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-DESCRIPTION="library and tools for managing linux kernel modules"
-HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
-
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="debug doc lzma static-libs +tools zlib"
-
-RDEPEND="!sys-apps/module-init-tools
- !sys-apps/modutils
- lzma? ( app-arch/xz-utils )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- doc? ( dev-util/gtk-doc )
- lzma? ( virtual/pkgconfig )
- zlib? ( virtual/pkgconfig )"
-
-# Upstream does not support running the test suite with custom configure flags.
-# I was also told that the test suite is intended for kmod developers.
-# So we have to restrict it.
-# See bug #408915.
-RESTRICT="test"
-
-src_prepare()
-{
- if [ ! -e configure ]; then
- if use doc; then
- gtkdocize --copy --docdir libkmod/docs || die
- else
- touch libkmod/docs/gtk-doc.make
- fi
- eautoreconf
- else
- elibtoolize
- fi
-}
-
-src_configure()
-{
- # http://bugs.gentoo.org/410865
- if has_version '<sys-libs/zlib-1.2.6'; then
- export zlib_CFLAGS="-I/usr/include"
- export zlib_LIBS="-lz"
- fi
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable tools) \
- $(use_enable debug) \
- $(use_enable doc gtk-doc) \
- $(use_with lzma xz) \
- $(use_with zlib)
-}
-
-src_install()
-{
- default
-
- find "${D}" -name libkmod.la -exec rm -f {} +
-
- if use tools; then
- dodir /bin
- dosym /usr/bin/kmod /bin/lsmod
- dodir /sbin
- local cmd
- for cmd in depmod insmod modinfo modprobe rmmod; do
- dosym /usr/bin/kmod /sbin/${cmd}
- done
- fi
-}