summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-09 01:55:28 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-09 01:55:28 +0000
commita0c3302593a998406e79a529cf3ae0d4d8f0812a (patch)
treebabfbb40cfa81f5870ed927446b647ded170b233 /sys-apps/kmod
parentcleanup wrt bug 356615. (diff)
downloadgentoo-2-a0c3302593a998406e79a529cf3ae0d4d8f0812a.tar.gz
gentoo-2-a0c3302593a998406e79a529cf3ae0d4d8f0812a.tar.bz2
gentoo-2-a0c3302593a998406e79a529cf3ae0d4d8f0812a.zip
Do not statically link libkmod #493630 by Nikoli.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-apps/kmod')
-rw-r--r--sys-apps/kmod/ChangeLog8
-rw-r--r--sys-apps/kmod/files/kmod-15-dynamic-kmod.patch16
-rw-r--r--sys-apps/kmod/kmod-15-r1.ebuild128
3 files changed, 151 insertions, 1 deletions
diff --git a/sys-apps/kmod/ChangeLog b/sys-apps/kmod/ChangeLog
index e00e9769cb4f..180414d4c077 100644
--- a/sys-apps/kmod/ChangeLog
+++ b/sys-apps/kmod/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/kmod
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.118 2013/12/08 18:22:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.119 2013/12/09 01:55:28 vapier Exp $
+
+*kmod-15-r1 (09 Dec 2013)
+
+ 09 Dec 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/kmod-15-dynamic-kmod.patch, +kmod-15-r1.ebuild:
+ Do not statically link libkmod #493630 by Nikoli.
08 Dec 2013; Markus Meier <maekke@gentoo.org> kmod-15.ebuild:
arm stable, bug #487338
diff --git a/sys-apps/kmod/files/kmod-15-dynamic-kmod.patch b/sys-apps/kmod/files/kmod-15-dynamic-kmod.patch
new file mode 100644
index 000000000000..c93bea6d6a85
--- /dev/null
+++ b/sys-apps/kmod/files/kmod-15-dynamic-kmod.patch
@@ -0,0 +1,16 @@
+do not statically link kmod against its own libraries
+
+https://bugs.gentoo.org/493630
+http://thread.gmane.org/gmane.linux.kernel.modules/1206
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -817,7 +817,7 @@
+ @BUILD_TOOLS_TRUE@ tools/static-nodes.c
+
+ @BUILD_TOOLS_TRUE@tools_kmod_LDADD = libkmod/libkmod-util.la \
+-@BUILD_TOOLS_TRUE@ libkmod/libkmod-internal.la
++@BUILD_TOOLS_TRUE@ libkmod/libkmod.la
+
+
+ # ------------------------------------------------------------------------------
diff --git a/sys-apps/kmod/kmod-15-r1.ebuild b/sys-apps/kmod/kmod-15-r1.ebuild
new file mode 100644
index 000000000000..86f8a7937f4a
--- /dev/null
+++ b/sys-apps/kmod/kmod-15-r1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-15-r1.ebuild,v 1.1 2013/12/09 01:55:28 vapier Exp $
+
+EAPI=5
+inherit autotools eutils libtool multilib toolchain-funcs versionator
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+ inherit git-2
+else
+ SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="alpha amd64 arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86"
+fi
+
+DESCRIPTION="library and tools for managing linux kernel modules"
+HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc lzma +openrc static-libs +tools zlib"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+RESTRICT="test"
+
+RDEPEND="!sys-apps/module-init-tools
+ !sys-apps/modutils
+ lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
+ openrc? ( !<sys-apps/openrc-0.12 )
+ zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ doc? ( dev-util/gtk-doc )
+ lzma? ( virtual/pkgconfig )
+ zlib? ( virtual/pkgconfig )"
+
+pkg_setup() {
+ [[ $(tc-getCPP) == *cpp ]] && ! version_is_at_least 4.6 $(gcc-version) && \
+ die "You need at least GNU GCC 4.6.x to build this package." #481020
+}
+
+src_prepare() {
+ if [ ! -e configure ]; then
+ if use doc; then
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ epatch "${FILESDIR}"/${PN}-15-dynamic-kmod.patch #493630
+ elibtoolize
+ fi
+
+ # Restore possibility of running --enable-static wrt #472608
+ sed -i \
+ -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
+ configure || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --with-rootlibdir=/$(get_libdir) \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable tools) \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_with lzma xz) \
+ $(use_with zlib)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if use tools; then
+ local bincmd sbincmd
+ for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
+ dosym /bin/kmod /sbin/${sbincmd}
+ done
+
+ # These are also usable as normal user
+ for bincmd in lsmod modinfo; do
+ dosym kmod /bin/${bincmd}
+ done
+ fi
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ softdep uhci_hcd pre: ehci_hcd
+ softdep ohci_hcd pre: ehci_hcd
+ EOF
+
+ insinto /lib/modprobe.d
+ doins "${T}"/usb-load-ehci-first.conf #260139
+
+ use openrc && doinitd "${FILESDIR}"/kmod-static-nodes
+}
+
+pkg_postinst() {
+ if use openrc; then
+ if [[ -L ${ROOT}etc/runlevels/boot/static-nodes ]]; then
+ ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
+ rm -f "${ROOT}"etc/runlevels/boot/static-nodes
+ fi
+
+ # Add kmod to the runlevel automatically if this is the first install of this package.
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if [[ -x ${ROOT}etc/init.d/kmod-static-nodes && -d ${ROOT}etc/runlevels/sysinit ]]; then
+ ln -s /etc/init.d/kmod-static-nodes "${ROOT}"/etc/runlevels/sysinit/kmod-static-nodes
+ fi
+ fi
+
+ if [[ -e ${ROOT}etc/runlevels/sysinit ]]; then
+ if [[ ! -e ${ROOT}etc/runlevels/sysinit/kmod-static-nodes ]]; then
+ ewarn
+ ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
+ ewarn "kernel modules to have required static nodes!"
+ ewarn "Run this command:"
+ ewarn "\trc-update add kmod-static-nodes sysinit"
+ fi
+ fi
+ fi
+}