summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-24 15:59:12 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-24 15:59:12 +0000
commitf5972dbcf35772d541a99f562765f9b63ffda71a (patch)
treea46f547a3ddf142f8d4477fbb055470e81fd75cf /sys-apps/man-db
parent[bump] dev-perl/Moo-1.0.1 (diff)
downloadgentoo-2-f5972dbcf35772d541a99f562765f9b63ffda71a.tar.gz
gentoo-2-f5972dbcf35772d541a99f562765f9b63ffda71a.tar.bz2
gentoo-2-f5972dbcf35772d541a99f562765f9b63ffda71a.zip
Fix building with glibc-2.16+ #427252 by Oschtan.
Diffstat (limited to 'sys-apps/man-db')
-rw-r--r--sys-apps/man-db/ChangeLog6
-rw-r--r--sys-apps/man-db/files/man-db-2.6.1-no-gets.patch24
-rw-r--r--sys-apps/man-db/man-db-2.6.1.ebuild12
3 files changed, 37 insertions, 5 deletions
diff --git a/sys-apps/man-db/ChangeLog b/sys-apps/man-db/ChangeLog
index 10526be0da7b..d1d299b6b916 100644
--- a/sys-apps/man-db/ChangeLog
+++ b/sys-apps/man-db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/man-db
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.29 2012/05/24 03:07:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/ChangeLog,v 1.30 2012/07/24 15:59:12 vapier Exp $
+
+ 24 Jul 2012; Mike Frysinger <vapier@gentoo.org> man-db-2.6.1.ebuild,
+ +files/man-db-2.6.1-no-gets.patch:
+ Fix building with glibc-2.16+ #427252 by Oschtan.
24 May 2012; Mike Frysinger <vapier@gentoo.org> man-db-2.6.0.2.ebuild,
man-db-2.6.1.ebuild:
diff --git a/sys-apps/man-db/files/man-db-2.6.1-no-gets.patch b/sys-apps/man-db/files/man-db-2.6.1-no-gets.patch
new file mode 100644
index 000000000000..787e6901bc07
--- /dev/null
+++ b/sys-apps/man-db/files/man-db-2.6.1-no-gets.patch
@@ -0,0 +1,24 @@
+https://bugs.gentoo.org/427252
+
+hack until man-db pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/gnulib/lib/stdio.in.h
++++ b/gnulib/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
+
diff --git a/sys-apps/man-db/man-db-2.6.1.ebuild b/sys-apps/man-db/man-db-2.6.1.ebuild
index a4b9253afaf1..a72dcd697f54 100644
--- a/sys-apps/man-db/man-db-2.6.1.ebuild
+++ b/sys-apps/man-db/man-db-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.1.ebuild,v 1.3 2012/05/24 03:07:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man-db/man-db-2.6.1.ebuild,v 1.4 2012/07/24 15:59:12 vapier Exp $
EAPI="4"
@@ -32,6 +32,10 @@ pkg_setup() {
enewuser man 13 -1 /usr/share/man man
}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.6.1-no-gets.patch #427252
+}
+
src_configure() {
export ac_cv_lib_z_gzopen=$(usex zlib)
econf \
@@ -42,7 +46,7 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}"
- dodoc README ChangeLog NEWS docs/{HACKING,TODO}
- use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+ default
+ dodoc docs/{HACKING,TODO}
+ use static-libs || find "${ED}"/usr/ -name '*.la' -delete
}