summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-12 02:04:47 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-12 02:04:47 +0000
commita7edf210c0b5d21e83c8332a8884a0b828912eb6 (patch)
treeb1b342fedd695834f82a3ed58e6021cb360b039d /sys-apps/man
parentyes I broke a digest somehow (diff)
downloadgentoo-2-a7edf210c0b5d21e83c8332a8884a0b828912eb6.tar.gz
gentoo-2-a7edf210c0b5d21e83c8332a8884a0b828912eb6.tar.bz2
gentoo-2-a7edf210c0b5d21e83c8332a8884a0b828912eb6.zip
Add support for bzip2 pages to man2html.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'sys-apps/man')
-rw-r--r--sys-apps/man/ChangeLog8
-rw-r--r--sys-apps/man/files/digest-man-1.6e-r23
-rw-r--r--sys-apps/man/files/man-1.6e-man2html-bzip2.patch51
-rw-r--r--sys-apps/man/man-1.6e-r2.ebuild127
4 files changed, 188 insertions, 1 deletions
diff --git a/sys-apps/man/ChangeLog b/sys-apps/man/ChangeLog
index 925d944c4841..09b7ae97a1fa 100644
--- a/sys-apps/man/ChangeLog
+++ b/sys-apps/man/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/man
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.106 2007/01/06 01:34:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/ChangeLog,v 1.107 2007/01/12 02:04:47 vapier Exp $
+
+*man-1.6e-r2 (12 Jan 2007)
+
+ 12 Jan 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/man-1.6e-man2html-bzip2.patch, +man-1.6e-r2.ebuild:
+ Add support for bzip2 pages to man2html.
*man-1.6e-r1 (06 Jan 2007)
diff --git a/sys-apps/man/files/digest-man-1.6e-r2 b/sys-apps/man/files/digest-man-1.6e-r2
new file mode 100644
index 000000000000..69ec127910e1
--- /dev/null
+++ b/sys-apps/man/files/digest-man-1.6e-r2
@@ -0,0 +1,3 @@
+MD5 d8187cd756398baefc48ba7d60ff6a8a man-1.6e.tar.gz 252657
+RMD160 486099dc1b34fe86a2c1d19b7c89dc19b9787837 man-1.6e.tar.gz 252657
+SHA256 022faf23844eabb3662eabb105836925dd83bedda10271e2450a5bc5b61a5b5f man-1.6e.tar.gz 252657
diff --git a/sys-apps/man/files/man-1.6e-man2html-bzip2.patch b/sys-apps/man/files/man-1.6e-man2html-bzip2.patch
new file mode 100644
index 000000000000..6ca5298c1012
--- /dev/null
+++ b/sys-apps/man/files/man-1.6e-man2html-bzip2.patch
@@ -0,0 +1,51 @@
+--- man2html/glimpse_filters
++++ man2html/glimpse_filters
+@@ -1,3 +1,4 @@
++*.bz2 bzip2 -d -c
+ *.gz gzip -d -c
+ *.Z gzip -d -c
+
+--- man2html/scripts/cgi-bin/man/man2html
++++ man2html/scripts/cgi-bin/man/man2html
+@@ -87,6 +87,9 @@
+ if [ -r "$PAGE" ]
+ then
+ case "$PAGE" in
++ *.bz2)
++ bzcat "$PAGE" | "$MAN2HTML" "$LL" -D "$PAGE"
++ ;;
+ *.gz)
+ zcat "$PAGE" | "$MAN2HTML" "$LL" -D "$PAGE"
+ ;;
+@@ -94,6 +97,9 @@
+ "$MAN2HTML" "$LL" "$PAGE"
+ ;;
+ esac
++elif [ -r "$PAGE".bz2 ]
++then
++ bzcat "$PAGE".bz2 | "$MAN2HTML" "$LL" -D "$PAGE"
+ elif [ -r "$PAGE".gz ]
+ then
+ zcat "$PAGE".gz | "$MAN2HTML" "$LL" -D "$PAGE"
+--- man2html/scripts/cgi-bin/man/mansearch
++++ man2html/scripts/cgi-bin/man/mansearch
+@@ -153,7 +153,7 @@
+ }
+ print "<DT> <a href=\"" cgipath "/man2html?" fullname "\">";
+ textname = filename;
+- sub(/\.(gz)|Z|z$/, "", textname);
++ sub(/\.(gz)|(bz2)|Z|z$/, "", textname);
+ sub(/\./, "(", textname);
+ textname = textname ")";
+ print textname;
+--- man2html/scripts/cgi-bin/man/mansec
++++ man2html/scripts/cgi-bin/man/mansec
+@@ -128,7 +128,7 @@
+ # Print out alphabetic quick index and other links
+ }
+ # Split page.n into "page" and "n" and generate an entry
+- sub(/[.]([zZ]|(gz))$/, "", manpage);
++ sub(/[.]([zZ]|(gz)|(bz2))$/, "", manpage);
+ match(manpage, /[.][^.]+$/);
+ title = substr(manpage, 1, RSTART - 1);
+ if (section != "all") {
diff --git a/sys-apps/man/man-1.6e-r2.ebuild b/sys-apps/man/man-1.6e-r2.ebuild
new file mode 100644
index 000000000000..11f3cece5be1
--- /dev/null
+++ b/sys-apps/man/man-1.6e-r2.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/man/man-1.6e-r2.ebuild,v 1.1 2007/01/12 02:04:47 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Standard commands to read man pages"
+HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
+SRC_URI="http://primates.ximian.com/~flucifredi/man/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="nls? ( sys-devel/gettext )"
+DEPEND=">=sys-apps/groff-1.18
+ !sys-apps/man-db"
+PROVIDE="virtual/man"
+
+pkg_setup() {
+ enewgroup man 15
+ enewuser man 13 -1 /usr/share/man man
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # add support for bzip2 pages
+ epatch "${FILESDIR}"/man-1.6e-man2html-bzip2.patch
+
+ # We love to cross-compile
+ epatch "${FILESDIR}"/man-1.6-cross-compile.patch
+
+ # Fix search order in man.conf so that system installed manpages
+ # will be found first ...
+ epatch "${FILESDIR}"/man-1.5p-search-order.patch
+
+ # For groff-1.18 or later we need to call nroff with '-c'
+ epatch "${FILESDIR}"/man-1.5m-groff-1.18.patch
+
+ # makewhatis traverses manpages twice, as default manpath
+ # contains two directories that are symlinked together
+ epatch "${FILESDIR}"/man-1.5p-defmanpath-symlinks.patch
+
+ # add more sections to default search path
+ epatch "${FILESDIR}"/man-1.6b-more-sections.patch
+
+ # cut out symlinked paths #90186
+ epatch "${FILESDIR}"/man-1.6c-cut-duplicate-manpaths.patch
+
+ # Fedora patches
+ epatch "${FILESDIR}"/man-1.5m2-apropos.patch
+
+ # Fixes compilation in FreeBSD wrt #138123
+ epatch "${FILESDIR}"/man-1.6d-fbsd.patch
+
+ epatch "${FILESDIR}"/man-1.6e-dont-kill-shebangs.patch #159192
+ epatch "${FILESDIR}"/man-1.6e-headers.patch
+
+ strip-linguas $(eval $(grep ^LANGUAGES= configure) ; echo ${LANGUAGES//,/ })
+}
+
+src_compile() {
+ tc-export CC BUILD_CC
+
+ local mylang=
+ if use nls ; then
+ if [[ -z ${LINGUAS} ]] ; then
+ mylang="all"
+ else
+ mylang="${LINGUAS// /,}"
+ fi
+ else
+ mylang="none"
+ fi
+ ./configure \
+ -confdir=/etc \
+ +sgid +fhs \
+ +lang ${mylang} \
+ || die "configure failed"
+
+ append-ldflags $(bindnow-flags)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}" install || die "make install failed"
+ dosym man /usr/bin/manpath
+
+ dodoc LSM README* TODO
+
+ # makewhatis only adds man-pages from the last 24hrs
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/makewhatis.cron makewhatis
+
+ keepdir /var/cache/man
+ diropts -m0775 -g man
+ local mansects=$(grep ^MANSECT "${D}"/etc/man.conf | cut -f2-)
+ for x in ${mansects//:/ } ; do
+ keepdir /var/cache/man/cat${x}
+ done
+}
+
+pkg_postinst() {
+ einfo "Forcing sane permissions onto ${ROOT}/var/cache/man (Bug #40322)"
+ chown -R root:man "${ROOT}"/var/cache/man
+ chmod -R g+w "${ROOT}"/var/cache/man
+ [[ -e ${ROOT}/var/cache/man/whatis ]] \
+ && chown root:0 "${ROOT}"/var/cache/man/whatis
+
+ echo
+
+ local f files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ for f in ${files} ; do
+ [[ ${f} == */etc/cron.daily/makewhatis ]] && continue
+ [[ $(md5sum "${f}") == "8b2016cc778ed4e2570b912c0f420266 "* ]] \
+ && rm -f "${f}"
+ done
+ files=$(ls "${ROOT}"/etc/cron.{daily,weekly}/makewhatis{,.cron} 2>/dev/null)
+ if [[ ${files/$'\n'} != ${files} ]] ; then
+ ewarn "You have multiple makewhatis cron files installed."
+ ewarn "You might want to delete all but one of these:"
+ ewarn ${files}
+ fi
+}