summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2013-10-10 18:38:37 +0000
committerTony Vroon <chainsaw@gentoo.org>2013-10-10 18:38:37 +0000
commit82f3fef14786c797eba344d04cdd60cf84caba38 (patch)
treef5c37d24fbb62eeedcc2ea6c5bc58c835cc7c308 /sys-apps/memtest86
parentVersion bump, drop old (diff)
downloadgentoo-2-82f3fef14786c797eba344d04cdd60cf84caba38.tar.gz
gentoo-2-82f3fef14786c797eba344d04cdd60cf84caba38.tar.bz2
gentoo-2-82f3fef14786c797eba344d04cdd60cf84caba38.zip
Version bump, as requested by Chris "blackstar86" in bug #472704.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'sys-apps/memtest86')
-rw-r--r--sys-apps/memtest86/ChangeLog10
-rw-r--r--sys-apps/memtest86/files/memtest86-4.3.3-build.patch43
-rw-r--r--sys-apps/memtest86/memtest86-4.3.3.ebuild74
3 files changed, 125 insertions, 2 deletions
diff --git a/sys-apps/memtest86/ChangeLog b/sys-apps/memtest86/ChangeLog
index 26a0e027bb34..a08a74e583e8 100644
--- a/sys-apps/memtest86/ChangeLog
+++ b/sys-apps/memtest86/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/memtest86
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.41 2012/07/02 11:00:47 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/ChangeLog,v 1.42 2013/10/10 18:38:37 chainsaw Exp $
+
+*memtest86-4.3.3 (10 Oct 2013)
+
+ 10 Oct 2013; Tony Vroon <chainsaw@gentoo.org> +memtest86-4.3.3.ebuild,
+ +files/memtest86-4.3.3-build.patch:
+ Version bump, as requested by Chris "blackstar86" in bug #472704.
*memtest86-4.0s (02 Jul 2012)
diff --git a/sys-apps/memtest86/files/memtest86-4.3.3-build.patch b/sys-apps/memtest86/files/memtest86-4.3.3-build.patch
new file mode 100644
index 000000000000..2c5906ad5cad
--- /dev/null
+++ b/sys-apps/memtest86/files/memtest86-4.3.3-build.patch
@@ -0,0 +1,43 @@
+diff -uNr src.orig/Makefile src/Makefile
+--- src.orig/Makefile 2013-10-10 19:35:27.354179645 +0100
++++ src/Makefile 2013-10-10 19:38:07.344184547 +0100
+@@ -8,11 +8,9 @@
+ #
+ FDISK=/dev/fd0
+
+-AS=as -32
+-CC=gcc
++ASFLAGS=-32
+
+-CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
+- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
++CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin -ffreestanding -fPIC -fno-stack-protector $(SMP_FL)
+
+ OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
+ config.o memsize.o error.o smp.o cpuid.o vmem.o random.o
+@@ -23,7 +21,7 @@
+ # symbols and then link it dynamically so I have full
+ # relocation information
+ memtest_shared: $(OBJS) memtest_shared.lds Makefile
+- $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds \
++ $(LD) --warn-constructors --warn-common -static -T memtest_shared.lds -m elf_i386 \
+ -o $@ $(OBJS) && \
+ $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
+
+@@ -50,7 +48,7 @@
+ $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
+
+ test.o: test.c
+- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
++ $(CC) -c $(CFLAGS:-fPIC=) -o $@ $<
+
+ random.o: random.c
+ $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
+@@ -72,3 +70,7 @@
+ dos: all
+ cat mt86+_loader memtest.bin > memtest.exe
+
++head.o: head.s
++bootsect.o: bootsect.s
++setup.o: setup.s
++
diff --git a/sys-apps/memtest86/memtest86-4.3.3.ebuild b/sys-apps/memtest86/memtest86-4.3.3.ebuild
new file mode 100644
index 000000000000..1f6ec43c164e
--- /dev/null
+++ b/sys-apps/memtest86/memtest86-4.3.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/memtest86/memtest86-4.3.3.ebuild,v 1.1 2013/10/10 18:38:37 chainsaw Exp $
+
+EAPI=5
+
+inherit mount-boot eutils toolchain-funcs
+
+DESCRIPTION="A stand alone memory test for x86 computers"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="http://www.memtest86.com/downloads/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="serial"
+S="${WORKDIR}/src"
+
+BOOTDIR=/boot/memtest86
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch #66630
+
+ sed -i -e 's,0x10000,0x100000,' memtest.lds || die
+
+ if use serial ; then
+ sed -i \
+ -e '/^#define SERIAL_CONSOLE_DEFAULT/s:0:1:' \
+ config.h \
+ || die "sed failed"
+ fi
+
+ cat - > "${T}"/39_${PN} <<EOF
+#!/bin/sh
+exec tail -n +3 \$0
+
+menuentry "${PN} ${PV}" {
+ linux16 ${BOOTDIR}/memtest
+}
+EOF
+
+ tc-export AS CC LD
+}
+
+src_test() { :; }
+
+src_install() {
+ insinto ${BOOTDIR}
+ newins memtest.bin memtest
+ dosym memtest ${BOOTDIR}/memtest.bin
+
+ exeinto /etc/grub.d
+ doexe "${T}"/39_${PN}
+
+ dodoc README README.build-process README.background
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+ elog
+ elog "memtest has been installed in ${BOOTDIR}/"
+ elog "You may wish to update your bootloader configs"
+ elog "by adding these lines:"
+ elog " - For grub2 just run grub-mkconfig, a configuration file is installed"
+ elog " as /etc/grub/39_${PN}"
+ elog " - For grub legacy: (replace '?' with correct numbers for your boot partition)"
+ elog " > title=${PN}"
+ elog " > root (hd?,?)"
+ elog " > kernel ${BOOTDIR}/memtest"
+ elog " - For lilo:"
+ elog " > image = ${BOOTDIR}/memtest"
+ elog " > label = ${PN}"
+ elog
+}