summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-06 19:29:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-06 19:29:16 +0000
commit54bc4c04d0dd0f710a62904d9481d76b035241e8 (patch)
tree94ad7a418afce5dd28459bf0c39c9f1c56255b91 /sys-apps/microcode-data
parentfix bug #419331 and add CDROM_NAME (diff)
downloadgentoo-2-54bc4c04d0dd0f710a62904d9481d76b035241e8.tar.gz
gentoo-2-54bc4c04d0dd0f710a62904d9481d76b035241e8.tar.bz2
gentoo-2-54bc4c04d0dd0f710a62904d9481d76b035241e8.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps/microcode-data')
-rw-r--r--sys-apps/microcode-data/ChangeLog10
-rw-r--r--sys-apps/microcode-data/microcode-data-20120606.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-apps/microcode-data/ChangeLog b/sys-apps/microcode-data/ChangeLog
index 8790ae1ca344..e96e670296a9 100644
--- a/sys-apps/microcode-data/ChangeLog
+++ b/sys-apps/microcode-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-data
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.17 2011/12/12 22:39:57 flameeyes Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.18 2012/06/06 19:29:16 flameeyes Exp $
+
+*microcode-data-20120606 (06 Jun 2012)
+
+ 06 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +microcode-data-20120606.ebuild:
+ Version bump.
*microcode-data-20111110 (12 Dec 2011)
diff --git a/sys-apps/microcode-data/microcode-data-20120606.ebuild b/sys-apps/microcode-data/microcode-data-20120606.ebuild
new file mode 100644
index 000000000000..5677a8d3411b
--- /dev/null
+++ b/sys-apps/microcode-data/microcode-data-20120606.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/microcode-data-20120606.ebuild,v 1.1 2012/06/06 19:29:16 flameeyes Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+NUM="21385"
+DESCRIPTION="Intel IA32 microcode update data"
+HOMEPAGE="http://urbanmyth.org/microcode/"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
+}
+
+src_compile() {
+ tc-env_build emake intel-microcode2ucode
+ ./intel-microcode2ucode microcode.dat || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r microcode.dat intel-ucode
+}
+
+pkg_postinst() {
+ elog "The microcode available for Intel CPUs has been updated. You'll need"
+ elog "to reload the code into your processor. If you're using the init.d:"
+ elog "/etc/init.d/microcode_ctl restart"
+}