summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Pfeifer <pfeifer@gentoo.org>2004-08-12 21:31:57 +0000
committerJay Pfeifer <pfeifer@gentoo.org>2004-08-12 21:31:57 +0000
commit25ab8554f7425089d835a78f5192f944f24ec657 (patch)
tree0b268ace48d7efe009bfbbf88afa7e530ab25660 /sys-apps/mindi/mindi-1.10.ebuild
parentEbuild fixes and clean-ups. (Manifest recommit) (diff)
downloadgentoo-2-25ab8554f7425089d835a78f5192f944f24ec657.tar.gz
gentoo-2-25ab8554f7425089d835a78f5192f944f24ec657.tar.bz2
gentoo-2-25ab8554f7425089d835a78f5192f944f24ec657.zip
Version bump and package masked testing version.
Diffstat (limited to 'sys-apps/mindi/mindi-1.10.ebuild')
-rw-r--r--sys-apps/mindi/mindi-1.10.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/sys-apps/mindi/mindi-1.10.ebuild b/sys-apps/mindi/mindi-1.10.ebuild
new file mode 100644
index 000000000000..eb301f4b8504
--- /dev/null
+++ b/sys-apps/mindi/mindi-1.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/mindi/mindi-1.10.ebuild,v 1.1 2004/08/12 21:30:21 pfeifer Exp $
+
+RESTRICT="nouserpriv"
+DESCRIPTION="A program that creates emergency boot disks/CDs using your kernel, tools and modules."
+HOMEPAGE="http://www.mondorescue.org/"
+SRC_URI="http://www.microwerks.net/~hugo/download/MondoCD/TGZS/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-arch/bzip2-0.9
+ >=sys-apps/mindi-kernel-1.0-r1
+ app-cdr/cdrtools
+ sys-libs/ncurses
+ sys-devel/binutils
+ sys-apps/gawk"
+
+pkg_setup () {
+ for i in ${FEATURES} ; do
+ if [ "${i}" = "userpriv" ] ; then
+ echo
+ ewarn "mindi cannot be installed if userpriv"
+ ewarn "is set within FEATURES."
+ ewarn "Please emerge mindi as follows:"
+ echo
+ ewarn "# FEATURES=\"-userpriv\" emerge mindi"
+ die "userpriv failure"
+ fi
+ done
+}
+
+src_unpack() {
+ unpack ${A} || die "Failed to unpack ${A}"
+ cd ${S}/rootfs || die
+ tar xzf symlinks.tgz || die "Failed to unpack symlinks.tgz"
+
+ # This will need to change when IA64 is tested. Onviously.
+ rm -f bin/busybox-ia64 sbin/parted2fdisk-ia64
+ mv bin/busybox-i386 bin/busybox
+}
+
+src_install() {
+ dodir /usr/sbin
+
+ dodir /usr/share/mindi
+ exeinto /usr/share/mindi
+ doexe analyze-my-lvm mindi parted2fdisk.pl
+
+ dosym /usr/share/mindi/mindi /usr/sbin/
+
+ insinto /usr/share/mindi
+ doins deplist.txt isolinux-H.cfg isolinux.cfg \
+ msg-txt sys-disk.raw.gz syslinux-H.cfg syslinux.cfg
+
+ cp -a Mindi/ aux-tools/ rootfs/ ${D}/usr/share/mindi/
+
+ dodoc CHANGES INSTALL README TODO
+}
+
+pkg_postinst() {
+ einfo "${P} was successfully installed."
+ einfo "Please read the associated docs for help."
+ einfo "Or visit the website @ ${HOMEPAGE}"
+ echo
+ ewarn "This package is still in unstable."
+ ewarn "Please report bugs to http://bugs.gentoo.org/"
+ ewarn "However, please do an advanced query to search for bugs"
+ ewarn "before reporting. This will keep down on duplicates."
+ echo
+}