summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-18 22:30:15 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-18 22:30:15 +0000
commitdd4fb9d0d2573137d49570e56d362cd3ae208867 (patch)
tree91aede4517cde1383a1abca9e4a4c385a1e78688 /sys-apps/modutils/modutils-2.4.27-r1.ebuild
parent#103008: ebuild path fix (diff)
downloadgentoo-2-dd4fb9d0d2573137d49570e56d362cd3ae208867.tar.gz
gentoo-2-dd4fb9d0d2573137d49570e56d362cd3ae208867.tar.bz2
gentoo-2-dd4fb9d0d2573137d49570e56d362cd3ae208867.zip
Fix by the PaX guys to remove executable stack markings.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-apps/modutils/modutils-2.4.27-r1.ebuild')
-rw-r--r--sys-apps/modutils/modutils-2.4.27-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/modutils/modutils-2.4.27-r1.ebuild b/sys-apps/modutils/modutils-2.4.27-r1.ebuild
new file mode 100644
index 000000000000..b23b08d7b5f8
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.4.27-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.4.27-r1.ebuild,v 1.1 2005/08/18 22:30:15 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Standard kernel module utilities"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/modutils/"
+SRC_URI="mirror://kernel/linux/utils/kernel/${PN}/v2.4/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="!virtual/modutils"
+PROVIDE="virtual/modutils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-alias.patch
+ epatch "${FILESDIR}"/${P}-gcc.patch
+ epatch "${FILESDIR}"/${P}-flex.patch
+ epatch "${FILESDIR}"/${P}-no-nested-function.patch
+}
+
+src_compile() {
+ econf \
+ --prefix=/ \
+ --disable-strip \
+ --enable-insmod-static \
+ --disable-zlib \
+ || die "./configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall prefix="${D}" || die "make install failed"
+ dodoc CREDITS ChangeLog NEWS README TODO
+}