summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-06-21 23:38:05 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-06-21 23:38:05 +0000
commite0307ba29a195fa03351c84a7b6d2d9435202267 (patch)
tree765319b3c19dcfeeb1bddfbca4001e92d4da0f55 /sys-apps/net-tools/net-tools-1.60-r4.ebuild
parentadd net-tools to build (diff)
downloadgentoo-2-e0307ba29a195fa03351c84a7b6d2d9435202267.tar.gz
gentoo-2-e0307ba29a195fa03351c84a7b6d2d9435202267.tar.bz2
gentoo-2-e0307ba29a195fa03351c84a7b6d2d9435202267.zip
bugfixes
Diffstat (limited to 'sys-apps/net-tools/net-tools-1.60-r4.ebuild')
-rw-r--r--sys-apps/net-tools/net-tools-1.60-r4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/net-tools/net-tools-1.60-r4.ebuild b/sys-apps/net-tools/net-tools-1.60-r4.ebuild
new file mode 100644
index 000000000000..201595847494
--- /dev/null
+++ b/sys-apps/net-tools/net-tools-1.60-r4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/net-tools/net-tools-1.60-r4.ebuild,v 1.1 2002/06/21 23:38:05 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="standard Linux network tools"
+SRC_URI="http://www.tazenda.demon.co.uk/phil/net-tools/${P}.tar.bz2"
+HOMEPAGE="http://sites.inka.de/lina/linux/NetTools/"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp ${FILESDIR}/config.h .
+ cp ${FILESDIR}/config.make .
+ cp Makefile Makefile.orig
+ sed -e "s/-O2 -Wall -g/${CFLAGS}/" Makefile.orig > Makefile
+ cd man
+ cp Makefile Makefile.orig
+ sed -e "s:/usr/man:/usr/share/man:" Makefile.orig > Makefile
+
+ if [ -z "`use nls`" ]
+ then
+ cd ${S}
+ mv config.h config.h.orig
+ sed 's:\(#define I18N\) 1:\1 0:' config.h.orig > config.h
+
+ mv config.make config.make.orig
+ sed 's:I18N=1:I18N=0:' config.make.orig > config.make
+ fi
+
+}
+
+src_compile() {
+ # Changing "emake" to "make" closes half of bug #820; configure is run from *inside*
+ # the Makefile, sometimes breaking parallel makes (if ./configure doesn't finish first)
+
+ make || die
+
+ if [ "`use nls`" ]
+ then
+ cd po
+ make || die
+ fi
+}
+
+src_install() {
+ make BASEDIR=${D} install || die
+ mv ${D}/bin/* ${D}/sbin
+ for i in hostname domainname netstat dnsdomainname ypdomainname nisdomainname
+ do
+ mv ${D}/sbin/${i} ${D}/bin
+ done
+ dodir /usr/bin
+ dosym /bin/hostname /usr/bin/hostname
+ if [ -z "`use bootcd`" ] && [ -z "`use build`" ]
+ then
+ dodoc COPYING README README.ipv6 TODO
+ else
+ #only install /bin/hostname
+ rm -rf ${D}/usr
+ rm -rf ${D}/sbin
+ rm -f ${D}/bin/{domainname,netstat,dnsdomainname}
+ rm -f ${D}/bin/{ypdomainname,nisdomainname}
+ fi
+}
+