summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-04-14 20:51:05 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-04-14 20:51:05 +0000
commit3736bbe75080a3da0720a18ae25ff7ba75006dc2 (patch)
tree7011147183b828a35e3fe526d683056c3bd7425d /sys-apps/openrc
parentSecurity bump, see bug #217232. Also fixes bug #217293. (diff)
downloadgentoo-2-3736bbe75080a3da0720a18ae25ff7ba75006dc2.tar.gz
gentoo-2-3736bbe75080a3da0720a18ae25ff7ba75006dc2.tar.bz2
gentoo-2-3736bbe75080a3da0720a18ae25ff7ba75006dc2.zip
get rid of issue with 'net.*' literally appearing
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'sys-apps/openrc')
-rw-r--r--sys-apps/openrc/ChangeLog6
-rw-r--r--sys-apps/openrc/openrc-0.2.1-r1.ebuild4
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sys-apps/openrc/ChangeLog b/sys-apps/openrc/ChangeLog
index cdeadd192680..715f0d5d46d9 100644
--- a/sys-apps/openrc/ChangeLog
+++ b/sys-apps/openrc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/openrc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.27 2008/04/12 00:39:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/ChangeLog,v 1.28 2008/04/14 20:51:05 cardoe Exp $
+
+ 14 Apr 2008; Doug Goldstein <cardoe@gentoo.org> openrc-0.2.1-r1.ebuild,
+ openrc-9999.ebuild:
+ get rid of issue with 'net.*' literally appearing
12 Apr 2008; Doug Goldstein <cardoe@gentoo.org> openrc-0.2.1-r1.ebuild,
openrc-9999.ebuild:
diff --git a/sys-apps/openrc/openrc-0.2.1-r1.ebuild b/sys-apps/openrc/openrc-0.2.1-r1.ebuild
index a0eab4162280..8014cd5da6d3 100644
--- a/sys-apps/openrc/openrc-0.2.1-r1.ebuild
+++ b/sys-apps/openrc/openrc-0.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r1.ebuild,v 1.5 2008/04/12 00:39:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-0.2.1-r1.ebuild,v 1.6 2008/04/14 20:51:05 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -158,7 +158,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in "${ROOT}"/etc/init.d/net.* ; do
+ for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."
diff --git a/sys-apps/openrc/openrc-9999.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index 7321513e1bdf..602e8a65b620 100644
--- a/sys-apps/openrc/openrc-9999.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.25 2008/04/12 00:39:26 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/openrc/openrc-9999.ebuild,v 1.26 2008/04/14 20:51:05 cardoe Exp $
inherit eutils flag-o-matic multilib toolchain-funcs
@@ -156,7 +156,7 @@ pkg_preinst() {
fi
# force net init.d scripts into symlinks
- for f in "${ROOT}"/etc/init.d/net.* ; do
+ for f in $(ls "${ROOT}"/etc/init.d/net.*) ; do
if [[ ! -L ${f} ]] ; then
elog "Moved net service '${f##*/}' to '${f##*/}.openrc.bak' to force a symlink."
elog "You should delete '${f##*/}.openrc.bak' if you don't need it."