summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-02-18 07:58:03 +0000
committerNed Ludd <solar@gentoo.org>2004-02-18 07:58:03 +0000
commitd5652320cc0973f078b2da3cf78c7f31002fcf92 (patch)
tree1d410c5a15c0a58e840d97a0c760cb9e040b82e6 /sys-apps/paxctl
parentLittle fixes, see bug 41146 (Manifest recommit) (diff)
downloadgentoo-2-d5652320cc0973f078b2da3cf78c7f31002fcf92.tar.gz
gentoo-2-d5652320cc0973f078b2da3cf78c7f31002fcf92.tar.bz2
gentoo-2-d5652320cc0973f078b2da3cf78c7f31002fcf92.zip
This is paxctl for controlling PaX flags on a per binary basis. PaX
is an intrusion prevention system that provides the best protection mechanisms against memory corruption bugs. Some applications are not compatible with certain features (due to design or bad engineering) and therefore they have to be exempted from certain enforcements. It is also possible to use PaX in soft mode where none of the protection mechanisms are active by default - here paxctl can be used to turn them on for selected programs (e.g., network daemons, programs that process network data such as mail clients, web browsers, etc). PaX and paxctl work on ELF executables, both of the standard ET_EXEC and the newer ET_DYN kind (older PaX releases referred to the latter as ET_DYN executables, these days they are called Position Independent Executables or PIEs for short).
Diffstat (limited to 'sys-apps/paxctl')
-rw-r--r--sys-apps/paxctl/ChangeLog20
-rw-r--r--sys-apps/paxctl/Manifest4
-rw-r--r--sys-apps/paxctl/files/digest-paxctl-0.21
-rw-r--r--sys-apps/paxctl/metadata.xml5
-rw-r--r--sys-apps/paxctl/paxctl-0.2.ebuild25
5 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/paxctl/ChangeLog b/sys-apps/paxctl/ChangeLog
new file mode 100644
index 000000000000..80b06719c5cc
--- /dev/null
+++ b/sys-apps/paxctl/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for sys-apps/paxctl
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/ChangeLog,v 1.1 2004/02/18 07:58:03 solar Exp $
+
+ 18 Feb 2004; <solar@gentoo.org> :
+ This is paxctl for controlling PaX flags on a per binary basis. PaX
+ is an intrusion prevention system that provides the best protection
+ mechanisms against memory corruption bugs. Some applications are not
+ compatible with certain features (due to design or bad engineering)
+ and therefore they have to be exempted from certain enforcements. It
+ is also possible to use PaX in soft mode where none of the protection
+ mechanisms are active by default - here paxctl can be used to turn
+ them on for selected programs (e.g., network daemons, programs that
+ process network data such as mail clients, web browsers, etc).
+
+ PaX and paxctl work on ELF executables, both of the standard ET_EXEC
+ and the newer ET_DYN kind (older PaX releases referred to the latter
+ as ET_DYN executables, these days they are called Position Independent
+ Executables or PIEs for short).
+
diff --git a/sys-apps/paxctl/Manifest b/sys-apps/paxctl/Manifest
new file mode 100644
index 000000000000..b372e7b3638a
--- /dev/null
+++ b/sys-apps/paxctl/Manifest
@@ -0,0 +1,4 @@
+MD5 b1708e26e77ec9211c80121ea133870a paxctl-0.2.ebuild 704
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 e49b8ea4699fedff7e6626e81ebfc4c8 ChangeLog 262
+MD5 7cd8adc34a7c0e7b400dcd24793ff4cf files/digest-paxctl-0.2 60
diff --git a/sys-apps/paxctl/files/digest-paxctl-0.2 b/sys-apps/paxctl/files/digest-paxctl-0.2
new file mode 100644
index 000000000000..9bf8722e56ba
--- /dev/null
+++ b/sys-apps/paxctl/files/digest-paxctl-0.2
@@ -0,0 +1 @@
+MD5 efb173644c2dbf75a7a244feb212529c paxctl-0.2.tar.gz 4786
diff --git a/sys-apps/paxctl/metadata.xml b/sys-apps/paxctl/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/paxctl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>
diff --git a/sys-apps/paxctl/paxctl-0.2.ebuild b/sys-apps/paxctl/paxctl-0.2.ebuild
new file mode 100644
index 000000000000..cd901c2eef0b
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.2.ebuild,v 1.1 2004/02/18 07:58:03 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~hppa ~ia64" ; # "~mips"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc >=sys-devel/binutils-2.14.90.0.8-r1"
+
+#S=${WORKDIR}/${P}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}