summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-20 02:40:04 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-20 02:40:04 +0000
commit5f02d619766ea292cd50625a1f4305b87e6bf0ec (patch)
tree72c558a439ec25b6745cac24a80f7e979973c4aa /sys-apps/pciutils
parentUtilise pambase and general cleanup. (diff)
downloadgentoo-2-5f02d619766ea292cd50625a1f4305b87e6bf0ec.tar.gz
gentoo-2-5f02d619766ea292cd50625a1f4305b87e6bf0ec.tar.bz2
gentoo-2-5f02d619766ea292cd50625a1f4305b87e6bf0ec.zip
Version bump #210722.
(Portage version: 2.2_pre2)
Diffstat (limited to 'sys-apps/pciutils')
-rw-r--r--sys-apps/pciutils/ChangeLog7
-rw-r--r--sys-apps/pciutils/pciutils-2.2.10.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-apps/pciutils/ChangeLog b/sys-apps/pciutils/ChangeLog
index 301118652c79..f55ebc569c36 100644
--- a/sys-apps/pciutils/ChangeLog
+++ b/sys-apps/pciutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/pciutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.128 2008/02/07 12:17:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/ChangeLog,v 1.129 2008/02/20 02:40:04 vapier Exp $
+
+*pciutils-2.2.10 (20 Feb 2008)
+
+ 20 Feb 2008; Mike Frysinger <vapier@gentoo.org> +pciutils-2.2.10.ebuild:
+ Version bump #210722.
07 Feb 2008; Raúl Porcel <armin76@gentoo.org> pciutils-2.2.9.ebuild:
alpha/ia64/sparc/x86 stable
diff --git a/sys-apps/pciutils/pciutils-2.2.10.ebuild b/sys-apps/pciutils/pciutils-2.2.10.ebuild
new file mode 100644
index 000000000000..0ba4143635e0
--- /dev/null
+++ b/sys-apps/pciutils/pciutils-2.2.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pciutils/pciutils-2.2.10.ebuild,v 1.1 2008/02/20 02:40:04 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Various utilities dealing with the PCI bus"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="network-cron zlib"
+
+DEPEND="zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.7-build.patch
+ epatch "${FILESDIR}"/pcimodules-${PN}-2.2.6.patch
+ epatch "${FILESDIR}"/${PN}-2.2.7-update-pciids-both-forms.patch
+ sed -i "/^LIBDIR=/s:/lib:/$(get_libdir):" Makefile
+}
+
+src_compile() {
+ export ZLIB=$(use zlib && echo yes || echo no)
+ tc-export AR CC RANLIB
+ emake OPT="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake install install-lib DESTDIR="${D}" || die
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/pciutils.cron update-pciids \
+ || die "Failed to install update cronjob"
+ fi
+
+ # Install both forms until HAL has migrated
+ if use zlib ; then
+ local sharedir="${D}/usr/share/misc"
+ elog "Providing a backwards compatability non-compressed pci.ids"
+ gzip -d <"${sharedir}"/pci.ids.gz >"${sharedir}"/pci.ids
+ fi
+}